LINUX.ORG.RU
решено ФорумAdmin

проблема с расшаривание папки


0

1

здрасти. подскажите пожалуйста где не прав - у меня xubuntu 1104. на подключенном через усб жестком диске пытаюсь расшарить папку для общего доступа, через кнопки управления самбой (не через редактирование конфиг файла) открываю доступ к папке, на этом диске, чтение и запись, полный доступ и все такое, но на компе с виндой не может на нее зайти, но видит. при таких же параметрах на папку расположенную на самом компе зайти может. плюсом ко всему, если в свойствах папок меняю права для «остальных» (чтение/запись) на злосчастной папке после изменения они переходят в исходное состояние (нет), в другой нет, изменяются и сохраняются. просьба тех кто любит язвить не суетиться. спасибо

Ответ на: комментарий от GomZaLeS

/media/GuLiVeR/video/Иностранное — это каталог на внешнем винте? покажи результат команды mount.

Если да, то у тебя стоят права, которые не позволяют считать процессу samba содержимое каталога /media/GuLiVeR/video/Иностранное, ибо ты разрешил чтение запись и исполнение только себе, пользователю gomzales, все остальные (и те кто с тобой в одной группе, и весь мир), не могут не то что файлы считать, содержимое каталога просмотреть не могут (вот эти 6 минусов, да-да).

adriano32 ★★★ ()
Ответ на: комментарий от adriano32

gomzales@gloptop:~/Рабочий стол$ mount

/dev/sda1 on / type ext4 (rw,errors=remount-ro,commit=0)

proc on /proc type proc (rw,noexec,nosuid,nodev)

none on /sys type sysfs (rw,noexec,nosuid,nodev)

fusectl on /sys/fs/fuse/connections type fusectl (rw)

none on /sys/kernel/debug type debugfs (rw)

none on /sys/kernel/security type securityfs (rw)

none on /dev type devtmpfs (rw,mode=0755)

none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)

none on /dev/shm type tmpfs (rw,nosuid,nodev)

none on /var/run type tmpfs (rw,nosuid,mode=0755)

none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)

/dev/sda5 on /home type ext4 (rw,commit=0)

binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)

/dev/sdb1 on /media/GuLiVeR type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)

GomZaLeS ()
Ответ на: комментарий от GomZaLeS

ну я так и думал. добавь прав на каталог /media/GuLiVeR, чтоб было 755, чтение и получение списка файлов разрешить всем. 777, как советует ipwww выше не стоит. для этого через гуй поставь права или выполни в консоли

chmod -fR 755 /media/GuLiVeR

adriano32 ★★★ ()
Ответ на: комментарий от GomZaLeS

Открыть в своём любимом файловом менеджере, правйо клавишей по каталогу /media/GuLiVeR, свойства, найти где прописаны права доступа, поставить что-то типа rwx|r-x|r-x

adriano32 ★★★ ()
Ответ на: комментарий от adriano32

выполнил chmod -fR 755 /media/GuLiVeR ни чего не изменилось. по прежнему зайти не может. в правах чтение/запись обнуляется

GomZaLeS ()
Ответ на: комментарий от adriano32

умнвр))) блин. так че делать то? забить? и скидывать по сети в их папки по требованию? а может быть дело в формате жесткого нтфс сейчас или какие то параметры может нужно добавить?

GomZaLeS ()
Ответ на: комментарий от adriano32

вот че он выдал(

gomzales@gloptop:~/Рабочий стол$ sudo mount -t ntfs-3g /dev/sdb1 /media/GuLiVeR -o rw,nosuid,nodev,blksize=4096,umask=755,uid=1000

WARNING: blksize option is ignored because ntfs-3g must calculate it.

fuse: failed to access mountpoint /media/GuLiVeR: Нет такого файла или каталога

GomZaLeS ()
Ответ на: комментарий от adriano32

встает. только не под рутом не попользоваться

gomzales@gloptop:~/Рабочий стол$ sudo ls -ld /media/GuLiVeR/video/Иностранное

d----w--w- 1 gomzales root 16384 2011-07-27 17:53 /media/GuLiVeR/video/Иностранное

GomZaLeS ()
Ответ на: комментарий от adriano32

и каждый раз монтировать через терминал не так удобно

GomZaLeS ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.