LINUX.ORG.RU
решено ФорумAdmin

linux quagga+ospf дружим со свичем edge-core


0

1

Добрый день! Уже неделю пытюсь понять почему quagga ospf под линуксом не хочет работать с ospf на edge-core ES4612.

internet — eth0(195.19.16.30/30)<сервер>eth1(192.168.0.1/24) — ES4612(vlan1(192.168.0.3/24),vlan2(10.10.10.9/29),vlan3(10.10.10.17/29),vlan4(10.10.10.25/29))

Соответственно, сервер должен через ospf получать маршруты на vlan2(10.10.10.9/29),vlan3(10.10.10.17/29),vlan4(10.10.10.25/29), которые забиты в коммутатор.

Настройки сервера:
-------------------------------------------
[root@testserv quagga]# cat ospfd.conf
!
! Zebra configuration saved from vty
! 2011/08/29 13:47:31
!
hostname ospfd
password zebra
log file /var/log/quagga/ospfd.log
!
debug ospf packet hello recv
debug ospf packet dd recv
debug ospf packet ls-request recv
debug ospf packet ls-update recv
debug ospf packet ls-ack recv
!
!
interface eth0
!
interface eth1
!
interface lo
!
interface pan0
!
router ospf
ospf router-id 192.168.0.1
passive-interface eth0
passive-interface lo
network 192.168.0.0/24 area 0.0.0.0
default-information originate
!
line vty
-----------------------------------

[root@testserv quagga]# cat zebra.conf
! -*- zebra -*-
!
! zebra sample configuration file
!
! $Id: zebra.conf.sample,v 1.1.1.1 2002/12/13 20:15:30 paul Exp $
!
hostname testserv0
password zebra
enable password zebra
debug zebra packet recv
log file /var/log/quagga/zebra.log
!
! Interface's description.
!
interface lo

interface eth0
ip address 195.19.16.30/30

interface eth1
ip address 192.168.0.1/24
multicast

router-id 192.168.0.1
ip forwarding
ip route 0.0.0.0/0 195.19.16.29

!log file zebra.log
--------------------------------
Конфиг свича:

router OSPF
redistribute static
redistribute connected
router-id 192.168.0.3
network 192.168.0.0 255.255.255.0 area 0.0.0.0



В итоге, сервер соседей видит, а свич нет. Если втыкаю рядом второй такой-же свич - по ospf друг-друга видят.

ospfd# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL
192.168.0.3 1 Init/DROther 31.373s 192.168.0.3 eth1:192.168.0.1 0 0 0

Подскажите, куда копать. А то может уже глаз замылился, очевидного не вижу?


Вот в логах, примерно так:
---------------------------------
cat ospfd.log
2011/08/29 14:21:28 OSPF: src [192.168.0.4],
2011/08/29 14:21:28 OSPF: dst [224.0.0.5]
2011/08/29 14:21:37 OSPF: ip_v 4
2011/08/29 14:21:37 OSPF: ip_hl 5
2011/08/29 14:21:37 OSPF: ip_tos 192
2011/08/29 14:21:37 OSPF: ip_len 68
2011/08/29 14:21:37 OSPF: ip_id 12829
2011/08/29 14:21:37 OSPF: ip_off 0
2011/08/29 14:21:37 OSPF: ip_ttl 1
2011/08/29 14:21:37 OSPF: ip_p 89
2011/08/29 14:21:37 OSPF: ip_sum 0xd3e5
2011/08/29 14:21:37 OSPF: ip_src 192.168.0.3
2011/08/29 14:21:37 OSPF: ip_dst 224.0.0.5
2011/08/29 14:21:37 OSPF: Hello received from [192.168.0.3] via [eth1:192.168.0.1]
2011/08/29 14:21:37 OSPF: src [192.168.0.3],
2011/08/29 14:21:37 OSPF: dst [224.0.0.5]
-----------------------------------------------
cat zebra.log
2011/08/29 13:52:18 ZEBRA: IRDP: Received shutdown notification.
2011/08/29 13:52:18 ZEBRA: Zebra 0.99.18 starting: vty@2601
2011/08/29 13:52:25 ZEBRA: zebra message received [ZEBRA_ROUTER_ID_ADD] 0
2011/08/29 13:52:25 ZEBRA: zebra message received [ZEBRA_INTERFACE_ADD] 0
2011/08/29 13:52:25 ZEBRA: zebra message received [ZEBRA_REDISTRIBUTE_DEFAULT_ADD] 0
2011/08/29 13:52:25 ZEBRA: zebra message received [ZEBRA_IPV4_ROUTE_ADD] 17

gich ()

> redistribute static

redistribute connected


А кто то же самое будет квагге говорить ? Ещё, возможно, надо будет metric-type например:

redistribute kernel metric-type 1
redistribute connected metric-type 1
redistribute static metric-type 1

И зачем default-information originate ? Именно квагга источник маршрута по умолчанию ?

AS ★★★★★ ()
Ответ на: комментарий от gich

> Вопрос то в том, что свич не видит сервер в соседях!

Это место не прочитал... Что tcpdump показывает ? Исходящий OSPF-трафик есть ? Файрволом не режется ?

AS ★★★★★ ()

На свиче

redistribute connected

это плохо. Лучше добавить

network 10.10.10.0 255.255.255.0 area 0.0.0.0

А иначе эти роуты не фильтруются/не агрегируются, и вообще это не по ГОСТам и не комильфо.

Но все равно странно что соседей не видит, мб проверить настройки портов-вланов.

И да, вот это вот вроде как не нужно

interface eth1 multicast <--- не нужно

redixin ★★★★ ()

> network 10.10.10.0 255.255.255.0 area 0.0.0.0

А, простите, это 4612, там такое не работает. ТП еджкора разводит руками. Мне тоже пришлось сделать redistribute connected, и всвязи с этим одна область (которая работает на этих вот 4612) приделана к остальной сети немного через жопу.

redixin ★★★★ ()
Ответ на: комментарий от redixin

Фаерволом точно ничего не режется. Принимает все.
Посмотрел еще раз в tcpdump -n -N -i eth1
16:52:08.576328 IP 195.19.16.30 > 224.0.0.5: OSPFv2, Hello, length: 48
16:52:10.027412 STP 802.1s, Rapid STP, CIST Flags [Proposal, Learn, Forward, Agreement]
16:52:10.036012 IP 192.168.0.3 > 224.0.0.5: OSPFv2, Hello, length: 44
16:52:12.027403 STP 802.1s, Rapid STP, CIST Flags [Proposal, Learn, Forward, Agreement]
16:52:14.027421 STP 802.1s, Rapid STP, CIST Flags [Proposal, Learn, Forward, Agreement]
16:52:16.027439 STP 802.1s, Rapid STP, CIST Flags [Proposal, Learn, Forward, Agreement]
16:52:18.027503 STP 802.1s, Rapid STP, CIST Flags [Proposal, Learn, Forward, Agreement]
16:52:18.577313 IP 195.19.16.30 > 224.0.0.5: OSPFv2, Hello, length: 48
16:52:20.027507 STP 802.1s, Rapid STP, CIST Flags [Proposal, Learn, Forward, Agreement]
16:52:20.036123 IP 192.168.0.3 > 224.0.0.5: OSPFv2, Hello, length: 44

Что-то мне кажется, 195.19.16.30 вот тут 195.19.16.30 > 224.0.0.5 что-то не так.

gich ()
Ответ на: комментарий от gich

Вычислил. Осталось правило в фаерволе, от предыдущих экспирементов и src адрес попадал под замес в таблице nat. Правило убрал - все поехало.

gich ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.