LINUX.ORG.RU
ФорумAdmin

Quagga ospf host<->quagga<->host помогите разобраться


0

0

Помогите начинающему специалисту

Поставлена задача: продемонстрировать работу quagga. "Демонстрационный макет" имеет следующую структуру:

host (комп с виндой) <-> router(комп c debian) <-> host(комп с виндой)

______192.168.0.1/24 <-> 192.168.0.121/24::192.168.1.114/24 <-> 192.168.1.1/24

_____________________________________eth0::eth1

Quagga запускается (zebra и ospfd, ошибок никаких не выдаёт), но ничего через рутер не пингуется. Пробовал прописывать различные варианты конфигов, но безрезультатно. Подсткажите, что необходимо прописать в этих конфигах. Вот последний (тоже нерабочий) вариант:

конфиг zebra:___________________________

hostname router

password z

!

interface eth0

link-detect

multicast

ipv6 nd suppress-ra

!

interface eth1

link-detect

multicast

ipv6 nd suppress-ra

!

interface lo

link-detect

multicast

!

ip route 192.168.0.0/24 eth0

ip route 192.168.1.0/24 eth1

!

line vty

!

end

конфиг ospfd:_______________________________

hostname ospfd

password z

enable password z

log stdout

!

interface eth0

ip ospf network non-broadcast

ip ospf authentication

!

interface eth1

ip ospf network non-broadcast

ip ospf authentication

!

interface lo

ip ospf network non-broadcast

ip ospf authentication

!

router ospf

network 192.168.0.0/24 area 0.0.0.0

network 192.168.1.0/24 area 0.0.0.1

neighbor 192.168.0.1

neighbor 192.168.1.1

!

line vty

!

end

__________________________________________ router# show ip route

Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,

I - ISIS, B - BGP, > - selected route, * - FIB route

K>* 0.0.0.0/0 via 192.168.0.1, eth0

C>* 127.0.0.0/8 is directly connected, lo

O 192.168.0.0/24 [110/10] is directly connected, eth0, 00:20:25

S 192.168.0.0/24 [1/0] is directly connected, eth0

C>* 192.168.0.0/24 is directly connected, eth0

O 192.168.1.0/24 [110/10] is directly connected, eth1, 00:20:25

S 192.168.1.0/24 [1/0] is directly connected, eth1

C>* 192.168.1.0/24 is directly connected, eth1

Re: Quagga ospf host<->quagga<->host помогите разобраться

>neighbor 192.168.0.1
>neighbor 192.168.1.1
Зачем ? Вы умудрились поднять ospf на винде ?
ip route 192.168.0.0/24 eth0
ip route 192.168.1.0/24 eth1
тоже не нужно. Само поймет

a_andry ()

Re: Quagga ospf host<->quagga<->host помогите разобраться

>neighbor 192.168.0.1 >neighbor 192.168.1.1 >Зачем ? Вы умудрились поднять ospf на винде ? >ip route 192.168.0.0/24 eth0 >ip route 192.168.1.0/24 eth1 >тоже не нужно. Само поймет

да, это лишнее, но и с этим и без - не идёт

>на виндовых машинах:

C:\>ipconfig/all

Настройка протокола IP для Windows 2000

Имя компьютера . . . . . . . . . : host

Основной DNS суффикс . . . . . . :

Тип узла . . . . . . . . . . . . : Широковещательный

Включена IP-маршрутизация . . . . : Да

Доверенный WINS-сервер . . . . . : Нет

Адаптер Ethernet Подключение по локальной сети:

DNS суффикс этого подключения . . :

Описание . . . . . . . . . . . . : LфряЄхЁ PCI Fast Ethernet эр юёэютх Realtek RTL8139(A)

Физический адрес. . . . . . . . . : 00-08-A1-7E-DF-DF

DHCP разрешен . . . . . . . . . . : Нет

IP-адрес . . . . . . . . . . . . : 192.168.1.1

Маска подсети . . . . . . . . . . : 255.255.255.0

Основной шлюз . . . . . . . . . . : 192.168.0.121

DNS-серверы . . . . . . . . . . . : 192.168.0.1

C:\>netstat -rn

Таблица маршрутов

===========================================================================

Список интерфейсов

0x1 ........................... MS TCP Loopback interface

0x1000003 ...00 08 a1 7e df df ...... NDIS 5.0 driver

===========================================================================

===========================================================================

Активные маршруты:

Сетевой адрес Маска сети Адрес шлюза Интерфейс

Метрика

0.0.0.0 0.0.0.0 192.168.0.121 192.168.1.1 1

127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1

192.168.1.0 255.255.255.0 192.168.1.1 192.168.1.1 1

192.168.1.1 255.255.255.255 127.0.0.1 127.0.0.1 1

192.168.1.255 255.255.255.255 192.168.1.1 192.168.1.1 1

224.0.0.0 224.0.0.0 192.168.1.1 192.168.1.1 1

255.255.255.255 255.255.255.255 192.168.1.1 192.168.1.1 1

Основной шлюз: 192.168.0.121

===========================================================================

Постоянные маршруты:

192.168.0.0 255.255.255.0 192.168.1.114 1

фаервола нет_________________________________________________________

>на шлюзе:

debian:~# ifconfig

eth0 Link encap:Ethernet HWaddr 00:13:D4:65:1E:54

inet addr:192.168.0.121 Bcast:192.168.0.255 Mask:255.255.255.0

inet6 addr: fe80::213:d4ff:fe65:1e54/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:61470 errors:0 dropped:0 overruns:0 frame:0

TX packets:29826 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:15891778 (15.1 MiB) TX bytes:5038134 (4.8 MiB)

Interrupt:201 Base address:0xd800

eth1 Link encap:Ethernet HWaddr 00:E0:4C:C0:99:53

inet addr:192.168.1.114 Bcast:192.168.1.255 Mask:255.255.255.0

inet6 addr: fe80::2e0:4cff:fec0:9953/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:20475 errors:0 dropped:0 overruns:0 frame:0

TX packets:745 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:1522638 (1.4 MiB) TX bytes:52541 (51.3 KiB)

Interrupt:209 Base address:0xd400

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MULTICAST MTU:16436 Metric:1

RX packets:266 errors:0 dropped:0 overruns:0 frame:0

TX packets:266 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:24399 (23.8 KiB) TX bytes:24399 (23.8 KiB)

debian:~# netstat -rn

Kernel IP routing table

Destination Gateway Genmask Flags MSS Window irtt Iface

192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1

192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0

debian:~# cat /proc/sys/net/ipv4/ip_forward

1

через терминал куаги:

router> show ip forwarding

IP forwarding is on

>фаервола нет ____________________________________________________

обе карточки на шлюзе пингуются, а дальше - нет

hostik ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.