LINUX.ORG.RU
ФорумAdmin

xl2tpd: настройка аутентификации pppd на сервере.


0

1

за пример настройки xl2tpd взял это http://sudouser.com/ustanovka-i-nastrojka-l2tp-servera-xl2tpd-ili-l2tpd.html

но вот клиент с сервером не соединяется. на сервере в лог попадает такое

/usr/sbin/pppd: The remote system is required to authenticate itself
/usr/sbin/pppd: but I couldn't find any suitable secret (password) for it to use to do so.
/usr/sbin/pppd: (None of the available passwords would let it use an IP address.)

если на сервере отключить аутентификацию, например прописать в файл /etc/ppp/options.l2tp опцию noauth то тогда соединение успешно устанавливается, но тогда к серверу может подключится кто угодно. Файлы /etc/ppp/chap-secrets на клиенте и на сервере одинаковые. Так что же ему еще нужно ?

У меня создается впечатление что pppd даже не смотрит в chap-secrets...

PS ОС - Debian Linux

>У меня создается впечатление что pppd даже не смотрит в chap-secrets...

а если require-chap/require-mschap прописать?

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

я слегка в непонятке, добавил debug и dump но в логах ничего нового не появилось... я было подумал что оно не читает этот файл но оно реагирует на добавление noauth в него....

вот полный вывод для сервера команды

# xl2tpd -D

xl2tpd[28996]: setsockopt recvref[22]: Protocol not available
xl2tpd[28996]: This binary does not support kernel L2TP.
xl2tpd[28996]: xl2tpd version xl2tpd-1.2.6 started on starter PID:28996
xl2tpd[28996]: Written by Mark Spencer, Copyright (C) 1998, Adtran, Inc.
xl2tpd[28996]: Forked by Scott Balmos and David Stipp, (C) 2001
xl2tpd[28996]: Inherited by Jeff McAdams, (C) 2002
xl2tpd[28996]: Forked again by Xelerance (www.xelerance.com) (C) 2006
xl2tpd[28996]: Listening on IP address 0.0.0.0, port 1701
xl2tpd[28996]: get_call: allocating new tunnel for host 95.81.49.201, port 1701.
xl2tpd[28996]: get_call: allocating new tunnel for host 95.81.49.201, port 1701.
xl2tpd[28996]: control_finish: Peer requested tunnel 51082 twice, ignoring second one.
xl2tpd[28996]: build_fdset: closing down tunnel 48671
xl2tpd[28996]: get_call: allocating new tunnel for host 95.81.49.201, port 1701.
xl2tpd[28996]: control_finish: Peer requested tunnel 51082 twice, ignoring second one.
xl2tpd[28996]: build_fdset: closing down tunnel 37052
xl2tpd[28996]: Connection established to 95.81.49.201, 1701.  Local: 17292, Remote: 51082 (ref=0/0).  LNS session is 'aqua.vanessa.org.ua'
xl2tpd[28996]: control_finish: Warning: Peer did not specify transmit speed
xl2tpd[28996]: start_pppd: I'm running: 
xl2tpd[28996]: "/usr/sbin/pppd" 
xl2tpd[28996]: "passive" 
xl2tpd[28996]: "nodetach" 
xl2tpd[28996]: "192.168.10.1:192.168.10.2" 
xl2tpd[28996]: "refuse-pap" 
xl2tpd[28996]: "name" 
xl2tpd[28996]: "starter" 
xl2tpd[28996]: "file" 
xl2tpd[28996]: "/etc/ppp/options.l2tpd" 
xl2tpd[28996]: "/dev/pts/4" 
xl2tpd[28996]: Call established with 95.81.49.201, Local: 32516, Remote: 23143, Serial: 1
/usr/sbin/pppd: The remote system is required to authenticate itself
/usr/sbin/pppd: but I couldn't find any suitable secret (password) for it to use to do so.
/usr/sbin/pppd: (None of the available passwords would let it use an IP address.)
xl2tpd[28996]: child_handler : pppd exited for call 23143 with code 1
xl2tpd[28996]: call_close: Call 32516 to 95.81.49.201 disconnected
xl2tpd[28996]: Terminating pppd: sending TERM signal to pid 29027
xl2tpd[28996]: control_finish: Connection closed to 95.81.49.201, port 1701 (Server closing), Local: 17292, Remote: 51082
xl2tpd[28996]: build_fdset: closing down tunnel 17292
^Cxl2tpd[28996]: death_handler: Fatal signal 2 received

vano_vvv ()
Ответ на: комментарий от vano_vvv
xl2tpd[28996]: start_pppd: I'm running: 
xl2tpd[28996]: "/usr/sbin/pppd" 
xl2tpd[28996]: "passive" 
xl2tpd[28996]: "nodetach" 
xl2tpd[28996]: "192.168.10.1:192.168.10.2" 
xl2tpd[28996]: "refuse-pap" 
xl2tpd[28996]: "name" 
xl2tpd[28996]: "starter" 
xl2tpd[28996]: "file" 
xl2tpd[28996]: "/etc/ppp/options.l2tpd" 
xl2tpd[28996]: "/dev/pts/4" 

опции debug и dump отсутствуют. кури ман по x2ltpd или какого хрена оно не хочет добавлять их к запуску pppd

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Я эти опции вписал в /etc/ppp/options.l2tpd туда же вписываю auth/noauth хотя опцией auth можно управлять из xl2tpd.conf добавив туда require authentication = yes

vano_vvv ()
Ответ на: комментарий от Pinkbyte

Пожалуйста

xl2tpd[30210]: start_pppd: I'm running: 
xl2tpd[30210]: "/usr/sbin/pppd" 
xl2tpd[30210]: "passive" 
xl2tpd[30210]: "nodetach" 
xl2tpd[30210]: "192.168.10.1:192.168.10.2" 
xl2tpd[30210]: "refuse-pap" 
xl2tpd[30210]: "auth" 
xl2tpd[30210]: "require-chap" 
xl2tpd[30210]: "name" 
xl2tpd[30210]: "starter" 
xl2tpd[30210]: "debug" 
xl2tpd[30210]: "file" 
xl2tpd[30210]: "/etc/ppp/options.l2tpd" 
xl2tpd[30210]: "/dev/pts/4" 
xl2tpd[30210]: Call established with 213.238.7.54, Local: 37510, Remote: 44326, Serial: 1
/usr/sbin/pppd: The remote system is required to authenticate itself
/usr/sbin/pppd: but I couldn't find any suitable secret (password) for it to use to do so.
/usr/sbin/pppd: (None of the available passwords would let it use an IP address.)

debug есть но выхлоп не изменился, в /var/log/syslog попало только то же самое

vano_vvv ()
Ответ на: комментарий от Pinkbyte

А что тогда будет с аутентификацией ? Я ж сервер настраиваю и не клиент, если не задать auth тогда к серверу каждый дурак подключится или нет ?

vano_vvv ()
Ответ на: комментарий от Pinkbyte
# cat /etc/ppp/chap-secrets 
# Secrets for authentication using CHAP
# client        server  secret                  IP addresses
vanessa         *       123456

он такой на обоих компьютерах.......

vano_vvv ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.