LINUX.ORG.RU

заставить работать mayavi


0

1

Как можно заставить работать mayavi?

> ./test.py
Traceback (most recent call last):
  File "./test.py", line 8, in <module>
    from enthought.mayavi import mlab
  File "/usr/lib/python2.6/site-packages/enthought/mayavi/mlab.py", line 27, in <module>
    from enthought.mayavi.tools.camera import view, roll, yaw, pitch, move
  File "/usr/lib/python2.6/site-packages/enthought/mayavi/tools/camera.py", line 23, in <module>
    from engine_manager import get_engine
  File "/usr/lib/python2.6/site-packages/enthought/mayavi/tools/engine_manager.py", line 9, in <module>
    from enthought.traits.api import HasTraits, Instance
ImportError: No module named api

ставил с opensuse.org, и пакета api там нет http://software.opensuse.org/search?q=traits api&baseproject=openSUSE:Fac...

$ pip search enthought
ets                       - Enthought Tool Suite meta-project

Там же есть mayavi. Тебе обязательно нужен rpm?

o ()
Ответ на: комментарий от o

так дело в том, что он у меня установлен

zypper se enthought

S | Имя                  | Заключение                                 | Тип                   
--+----------------------+--------------------------------------------+-----------------------
i | python-EnthoughtBase | Core packages for the Enthought Tool Suite | пакет                 
  | python-EnthoughtBase | Core packages for the Enthought Tool Suite | пакет с исходным кодом

scireseacher ()
Ответ на: комментарий от scireseacher

Ну может быть криво встал. В Сусе такое иногда бывает с питонопрограммами. Попробуй вручную установить.

o ()
Ответ на: комментарий от o

Порекомендуйте какие исходники лучше скачать, чтобы был полный набор пакетов сразу?

P.S. У меня пока смесь пакатов от SLED11SP1 b OpenSUSE11.3

scireseacher ()
Ответ на: комментарий от scireseacher

Если что, под установкой вручную я подразумевал pip install :)

o ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.