LINUX.ORG.RU
решено ФорумAdmin

Debian 6 & Openvz


0

1

Поставил на Debian 6 OpenVZ, настраиваю интерфейс venet0 чтобы он автоматом получал ip-адресс 192.168.100.1

# cat /etc/network
network/  networks  
root@ocb1:~# cat /etc/network/interfaces 
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
        address X.X.X.X
        netmask 255.255.255.224
        gateway X.X.X.X
auto venet0
iface venet0 inet static
        address 192.168.100.1
        netmask 255.255.255.0

но после ребута интерфейс не получает ip-адреса

# ifconfig 
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:560 (560.0 B)  TX bytes:560 (560.0 B)

venet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

в чем проблема ?

> в чем проблема ?
Интерфейс venet0 появляется позже, чем поднимаются интерфейсы?
Если руками сделать ifup -a, venet0 получит адрес?

AITap ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.