LINUX.ORG.RU
ФорумAdmin

Postfix+SASL2


0

0

поставил ostfix c поддержкой sasl. но при передаче письма сервер не просит пароль, в логах следующее: warning: SASL authentication failure: Password verification failed Sep 3 10:30:52 localhost postfix/smtpd[14510]: warning: unknown[xxx.xxx.xxx.xx]: SASL PLAIN authentication failed main.cf: smtpd_sasl_auth_enable = yes smtpd_sasl_security_options = noanonymous smtpd_sasl_local_domain= $mydestination smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, permit_auth_destination, reject_unauth_destination broken_sasl_auth_clients=yes smtpd.conf: pwcheck_method: auxprop mech_list: lodin plain Да, saslauthd запущен, но с опцией -a shadow с опцией -a sasldb запускаться не хочет пишет что такой механизм не знает :( Может у кого еть какие соображения?

anonymous

Ответ на: Re: Postfix+SASL2 от anonymous

Re: Re: Postfix+SASL2

Дело в том что mysql работает еще с 3 сайтами с очень большой посещаемостью так что найти там(в логах) что либо не представляется возможным :( Но имена пользователей выбираюся, знаю по томц , что если пользователя нет в базе то почтовик пинает письмо обратно, как только добавишь пользователя в базу письмо принимается нормально =)

anonymous ()
Ответ на: Re: Re: Postfix+SASL2 от anonymous

Re: Re: Re: Postfix+SASL2

Это значит, что postfix выбирает, но совершенно не факт, что sasl это делает...
у меня так было, пока не собрал нормально sasl
./configure --enable-plain --enable-login --enable-sql --with-mysql=/usr/include/mysql --with-plugindir=/usr/local/lib/sasl2 --disable-krb4 --with-pwcheck --enable-cram

dzoleg ()
Ответ на: Re: Re: Re: Postfix+SASL2 от dzoleg

Re: Re: Re: Re: Postfix+SASL2

собрал с этими опциями вот что в логах : Sep 4 16:55:30 localhost postfix/smtpd[11600]: warning: SASL authentication failure: Password verification failed Sep 4 16:55:30 localhost postfix/smtpd[11600]: warning: unknown[195.239.45.247]: SASL PLAIN authentication failed в логах базы только выборка транспорта и т.д. но парль никто не выбирает :( Вопрос: нужно ли чтобы был запущен saslauthd и если нужно то с каким параметром после -a я что то так и не понял !

anonymous ()
Ответ на: Re: Re: Re: Re: Postfix+SASL2 от anonymous

Re: Re: Re: Re: Re: Postfix+SASL2

для sasl пропиши в /etс/postfix/main.cf

smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes

smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination 

все остальное, что относится к sasl убери... хотя бы на время

saslauthd не нужен

dzoleg ()
Ответ на: Re: Re: Re: Re: Postfix+SASL2 от anonymous

Re: Re: Re: Re: Re: Postfix+SASL2

ну и вообще, проверь чтобы пути всех ключей совпадали с реальными путями именно в твоей системе.
--with-mysql=/usr/include/mysql --with-plugindir=/usr/local/lib/sasl2

dzoleg ()
Ответ на: Re: Re: Re: Re: Re: Postfix+SASL2 от dzoleg

Re: Re: Re: Re: Re: Re: Postfix+SASL2

--with-mysql=/usr/include/mysql когда собираю с этим флагом линкер ругается на -lmysqlclient и выпадает с ошибкой :(

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.