LINUX.ORG.RU
ФорумAdmin

Проблема авторизации Webmin


0

1

Доброго времени суток всем.

Суть проблемы такова.
Сервер стабильно работал около 6 месяцев с последней перезаливки. Процедуры заливки системы и настройки, примерно за 2.5 года, отработаны до автоматизма.
Как я сказал, последняя заливка была около 6 месяцев назад, с того момента всё работало исправно. Окало 2х недель назад обновил сервер до 11,04, в то же (примерно) время, обновил Webmin до версии 1,540, более им не пользовался. Около недели назад решил организовать туннель по 443 порту (сервер в роли серверной части туннеля, само собой), соответственно, 443 порт у Апача был отнят (закомментирован в /etc/apache2/ports.conf).
На днях потребовалось посетить панель Webmin, попытка входа (по адресу https://server:10000) послала с сообщением «Login failed. Please try again.»

1) Предположил, что нужно вернуть ssl для webmin. Отключил сервер туннеля, в /etc/apache2/ports.conf раскомментировал 443 порт, всё перезапустил. Положительного результата не последовало.
2) Отключил использование ssl у Webmin (/etc/webmin/miniserv.conf ssl=0). Рестарт. Результата нет.
3) Удалил текущую установленную версию webmin (sudo apt-get purge webmin), с последующей чисткой всего что нашел от него. Откатил на версию 1,480 (из пакета с официального сайта webmin). Результат отрицателен.

Браузер - локально установлены все популярные браузеры, попытки входа производились с разных компов из разных сетей (из локальной и удаленной сети) (так, на всякий случай).
Правильность пользователя/пароля - захожу под системным пользователем, ssh по данным пользователю и паролю логинит. По умолчанию, webmin просит войти именно по подобному пользователю.
Настройки какие либо не изменялись в ручную (кроме портов апача). Апач на данный момент работает исправно, MySQL работает исправно (пользователь и пароль не изменены и действуют (проверено)), остальные службы исправны/работают.

вот последний лог (всё, что имеется после переустановки webmin):

192.168.0.11 - - [28/May/2011:13:10:04 +0400] «GET / HTTP/1.1» 401 2346

192.168.0.11 - - [28/May/2011:13:10:23 +0400] «POST /session_login.cgi HTTP/1.1» 401 2397

192.168.0.11 - - [28/May/2011:13:14:19 +0400] «GET / HTTP/1.1» 401 2346

192.168.0.11 - - [28/May/2011:13:14:28 +0400] «POST /session_login.cgi HTTP/1.1» 401 2397


Блоклист пуст.

Очень прошу помощи.
Предложения типа «сноси и пользуйся ssh», не принимаю, пользуюсь, но и webmin нужен.

Благодарен за любые дельные предложения.
Сильно не пинайте, не гуру, знаю то, чему научен.

Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.