LINUX.ORG.RU
Форум — Admin  

PDC: SAMBA+OpenLDAP, вынь7


0

1

Помогите решить проблему: win7 ругается, что не видит домен:

При соединении к домену "N" произошла следующая ошибка:

Указанный домен не существует или к нему невозможно
подключиться.
Другие машины домен, естественно, видят,wins прописаны,
opennetкак здесь сказано, политики поправил;
ключики по самбовской вики тоже правил. Брэндмауэр остановлен.
В логах samba не могу найти причин (то ли не там ищу)

Вообще, если смотреть по времени изменения логов,
никакие логи не изменяются от ошибки винды.

pimiento ★
() автор топика
Ответ на: комментарий от zgen

На сервере ошибку не могу отыскать (в логах разве что:

May 16 15:06:02 authentica smbd[10510]: [2011/05/16 15:06:02.084957,  0] lib/util_sock.c:474(read_fd_with_timeout)
May 16 15:06:02 authentica smbd[10510]: [2011/05/16 15:06:02.085115,  0] lib/util_sock.c:1432(get_peer_addr_internal)
May 16 15:06:02 authentica smbd[10510]:   getpeername failed. Error was Transport endpoint is not connected
May 16 15:06:02 authentica smbd[10510]:   read_fd_with_timeout: client 0.0.0.0 read error = Connection reset by peer.
В форточках ошибка после того, как я введу логин/пароль
учётки с правами добавлять в домен.

pimiento ★
() автор топика
Ответ на: комментарий от pimiento

То, что вы привели - это нормально, не ошибка, просто вывод технической инфы.

1) Версия samba?
2) что за «политики» правили? O_o

zgen ★★★★★
()

Освежить Samb'у?

Windows Vista и 7 можно включить в домен только на достаточно свежей Samb'е, кажися начиная 3.4.

Camel ★★★★★
()
Ответ на: комментарий от zgen

1) samba.i386-3.5.2-60.fc8
2) Правил «Сетевая безопасность: минимальная сеансовая безопасность
для клиентов/сервера на базе NTLM SSP (убрал минимум)»
и «Сетевая безопасность: уровень проверки подлинности LAN Manager»
(поставил Отправлять LM и NTLM, использовать NTLMv2 если потребуют)

pimiento ★
() автор топика
Ответ на: комментарий от zgen

А вот ещё нашёл куда пишется после ошибки доступа информация:

[2011/05/16 17:22:31.592950,  1] smbd/server.c:240(cleanup_timeout_fn)
  Cleaning up brl and lock database after unclean shutdown
[2011/05/16 17:24:22.394036,  0] lib/util_sock.c:1432(get_peer_addr_internal)
  getpeername failed. Error was Transport endpoint is not connected
[2011/05/16 17:27:58.162779,  0] lib/util_sock.c:1432(get_peer_addr_internal)
  getpeername failed. Error was Transport endpoint is not connected
[2011/05/16 17:28:58.395989,  0] lib/util_sock.c:1432(get_peer_addr_internal)
  getpeername failed. Error was Transport endpoint is not connected
[2011/05/16 17:30:51.592105,  1] smbd/server.c:267(remove_child_pid)
  Scheduled cleanup of brl and lock database after unclean shutdown
[2011/05/16 17:31:11.592932,  1] smbd/server.c:240(cleanup_timeout_fn)
  Cleaning up brl and lock database after unclean shutdown
Не знаю: то ли это или не то.

pimiento ★
() автор топика
Ответ на: комментарий от pimiento

2) Правил «Сетевая безопасность:

Вот это все совсем-совсем зря. Никаких модификаций к дефолтовой win7, кроме

HKLM\System\CCS\Services\LanmanWorkstation\Parameters
DWORD DomainCompatibilityMode = 1
DWORD DNSNameResolutionRequired = 0

Со времени 3.4.9 делать НЕ НУЖНО.
http://wiki.samba.org/index.php/Windows7

Теперь ищите немодифицированную вами инсталляцию и пробуйте на ней.

zgen ★★★★★
()
Ответ на: комментарий от pimiento

А если воротить взад параметры?

Воротить можно, не проблема. Но только после того, как мы исключим проблемы сервера. (дабы не усугублять ситуацию) А для этого нужна нормальная винда, в которой ты еще не покопался своими ручищами. ;)

zgen ★★★★★
()
Ответ на: комментарий от zgen

Есть около 40 XP-шек, которые нормально подключаются к домену,
есть одна W7, в которой я копался, но в домен она заходит.
А вот эта W7, установленная с того же диска, находящаяся
в той же подсети, даже в тот же свитч что и другая 7ка воткнута,
не хочет подключаться к домену.

pimiento ★
() автор топика
Ответ на: комментарий от pimiento

Все в кучу пихать не надо, надо не лениться, поставить win7 в виртуалку, изменить 2 значения реестра и попытаться добавить в домен. Если не получится - результат сюда.

Надеюсь, не очень сложно? ;)

zgen ★★★★★
()
Ответ на: комментарий от zgen

Переустановил систему, отказался от обновлений, загрузился
и сразу же поправил эти ключики в реестре:

HKLM\System\CCS\Services\LanmanWorkstation\Parameters
            DWORD  DomainCompatibilityMode = 1
            DWORD  DNSNameResolutionRequired = 0
Перезагрузился, прописал адреса WINS-серверов, пробую войти в домен:
Ввожу имя домена, логин и пароль учётки с правами добавлять в домен;
В итоге всё равно «Указанный домен не существует или к нему невозможно
подключиться»

pimiento ★
() автор топика
Ответ на: комментарий от pimiento

На сервере в логах последние записи:

messages

May 17 08:46:31 authentica smbd[16881]: [2011/05/17 08:46:31.521544, 0] lib/util_sock.c:1432(get_peer_addr_internal)
May 17 08:46:31 authentica smbd[16881]: getpeername failed. Error was Transport endpoint is not connected
May 17 08:46:31 authentica smbd[16881]: [2011/05/17 08:46:31.522366, 0] lib/util_sock.c:675(write_data)
May 17 08:46:31 authentica smbd[16881]: [2011/05/17 08:46:31.522468, 0] lib/util_sock.c:1432(get_peer_addr_internal)
May 17 08:46:31 authentica smbd[16881]: getpeername failed. Error was Transport endpoint is not connected
May 17 08:46:31 authentica smbd[16881]: write_data: write failure in writing to client 0.0.0.0. Error Connection reset by peer
May 17 08:46:31 authentica smbd[16881]: [2011/05/17 08:46:31.522646, 0] smbd/process.c:79(srv_send_smb)
May 17 08:46:31 authentica smbd[16881]: Error writing 4 bytes to client. -1. (Transport endpoint is not connected)

samba/log.smbd

[2011/05/17 08:46:31.521544, 0] lib/util_sock.c:1432(get_peer_addr_internal)
getpeername failed. Error was Transport endpoint is not connected

pimiento ★
() автор топика
Ответ на: комментарий от pimiento

samba/log.smbd

Включить дебаг чуть больше и смотреть в лог-файл машины, которую добавляете в домен:
log file = /var/log/samba34/%m
log level = 2 (или 3, но лучше с 2х)

Содержимое базы wins какое?

zgen ★★★★★
()
Ответ на: комментарий от zgen

Ничего нового в логах не появилось. Пробовал и 3 и 2 уровни.

pimiento ★
() автор топика
Ответ на: комментарий от pimiento

getpeername failed. Error was Transport endpoint is not connected

В прямой и обратной зонах, случайно, не должны быть указаны записи для подключаемой машины?

markevichus ★★★
()
Ответ на: комментарий от markevichus
> 192.168.100.72
Server:         192.168.100.1
Address:        192.168.100.1#53

72.100.168.192.in-addr.arpa     name = ikogan.aqua.
> ikogan.aqua
Server:         192.168.100.1
Address:        192.168.100.1#53

Name:   ikogan.aqua
Address: 192.168.100.72

Это nslookup с сервера, к которому должны подключаться.

pimiento ★
() автор топика

Что примечательно: WinXP у меня легко и непринуждёнНо удалось в домен

pimiento ★
() автор топика

Вопрос закрыт: вердикт я дурак. Разъясняю:
Писал DomainCombabilityMode заместо DomainCompatibilityMode
Патч мелкомягких почему-то это дело не правит, а вот патч
от samba.org помог.


P.S. Как отдать звезду, а то стыдно так тупить?

pimiento ★
() автор топика
Ответ на: комментарий от pimiento

CompabilityMode конечно, уж не настолько же дурак

pimiento ★
() автор топика
Вы не можете добавлять комментарии в эту тему: топик перемещен в архив.