LINUX.ORG.RU
ФорумAdmin

Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)


0

0

Ну что... прочитал все связанное с этим, не работает.
Стоит wu-ftpd 2.6.1, в /etc/passwd прописал ftpusers:*:1003:1003:FTP Users:/usr/usr2/ftp/./:/etc/ftponly, в предполагаемом корневом каталоге ftp создал директорию /bin с файлом ls внутри, в /etc/ftpaccess указал:

guestgroup ftpusers

guestuser ftpusers

Но все равно можно черутиться куда захочешь, запарило это уже порядком, в чем же все-таки дело?
Может не обрабатывается ни черта этот ftpaccess, черт его знает, помогите разобраться одним словом.

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

Поставь proftpd, только желательно из CVS, так как в релизе аплоад
в пассивном режиме не работает.

Havoc ★★★★ ()

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

ftpd-BSD еще лучше. у него достаточно прописать в файле /etc/ftpchroot всех, кто не должен выходить за пределы домашнего каталога. ТОлько, если ставить буш, не забудь патчик наложить, а то там небольшую дырень обнаружили недавно.

anonymous ()

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

2 Havoc

Что означается "только желательно из CVS", я скачал последнюю имеющуюся версию proftpd-1.2.0rc2.

mrrc ()

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

В том, что ты скачал, нельзя делать аплоад в пассивном режиме,
получишь ошибку No PORT issued first.
Это в CVS уже пофиксили, но релиза с этим фиксом нет. Я наступил на эти грабли,
порылся в архиве их мэйллиста, там про это было написано.
Скачал с CVS, собрал и все ob.
Инструкцию смотри на http://www.proftpd.net/docs/cvs.html

Havoc ★★★★ ()

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

P.S. например, чтобы запирать в своих хоумах узеров из группы www,
в конфиге пишешь
DefaultRoot ~/ www

Никаких ls юзерам ложить не надо.

Havoc ★★★★ ()

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

Я что-то не совсем понял, что сделать то нужно с этим CVS и когда именно :)

mrrc ()

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

гы.. странно а у меня на wu-ftpd всё замечательно работает.. скомпилил с опцией -enable-ls вписал гвест группу создал вымышленный шелл ftponly и всё забегало.. юзеры качают файл в свои каталоги, причём они квотируются, затем они могут видеть свое хоз-во из браузера.... ну что то типа хостинга..

anonymous ()

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

Да на работе тоже все работает нормально, а вот дома такие вот дела.
А как ты ставил, следующим образом?

./configure --prefix/usr/local/wu-ftpd --enable-ls потом make и make install, так, по крайней мере, по ключам?

Есть большое подозрение, что файл /etc/ftpaccess не обрабатывается, отсюда и сабж.

Кстати, нельзя ли еще поподробнее о том, как делается квотирование тем же юзерам, man quota-ы мало чем помогают.

mrrc ()

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

С CVS ты логинишься на их CVS сервер и выкачиваешь этот proftpd.
Там же инструкция пошаговая есть. Дальше конфигуришь и собираешь, как обычно.

Проще всего квоту регулировать через edquota user.

Вот до чего линух доводит. Человек даже не знает, что такое CVS ;)

Havoc ★★★★ ()

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

Ладно, я все равно толком не понял про CVS, ну да ладно... то есть мне нужен другой дистрибутив что ли, с поддержкой CVS? C edquota user игрался, но как установить то квоту юзеру, открывается vi и что указывать то нужно? Да не линух тут, а FreeBSD 4.0

mrrc ()

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

Твою мать, уже все сделал, что только можно, перечитал вот эту статью http://www.mgul.ac.ru/~t-alex/Linux/item/wu-ftpd.htm, все равно остается возможность подняться выше указанной корневой директории, при заходе броузером ftp://login_name:password@address сразу открывает корень / всей системы в целом.

Я уже не в силах...

mrrc ()

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

В vi вместо стоящих там чисел указываешь нужные тебе и сохраняешь файл.
Не забудь включить квоту на раздел ;)

команда cvs на фре есть, там же на сайте написано, что в командной строке 
набирать. Если сделаешь все, как там написано, то у тебя появится каталог
со свежайшими исходниками proftpd

cvs -d :pserver:anonymous@proftpd.org:/var/proftpd login
Вводишь пароль proftpd
cvs -d :pserver:anonymous@proftpd.org:/var/proftpd checkout proftpd-1.2
cvs -d :pserver:anonymous@proftpd.org:/var/proftpd logout

После этого у тебя появится каталог proftpd-1.2 со свежими сырцами.
Три команды всего.

Инфа про CVS: http://alexm.here.ru/cvs-ru/cvs-ru.html

Havoc ★★★★ ()

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

Спасибо, все скачал По поводу квот, есть вопросы, как бы с тобою связаться то бы? мыло что ли оставь, вот мое mrrc@ungvar.com

mrrc ()

Re: Так и не смог сделать чтобы при заходе по ftp нельзя было подняться выше... (+)

можно глупое предположение? --prefix=/usr/local => править надо /usr/local/etc/ftpaccess ? :) вдруг поможет :) или энтот wu-ftpd всегда в /etc лезет?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.