LINUX.ORG.RU
ФорумAdmin

Sagr вываливается с ошибкой


0

1

Подскажите, плиз, мож что можно в параметрах сарга выставить, чтоб он не вылетал с такой ошибкой


/usr/local/bin/sarg
SARG: getword loop detected after 256 bytes.62%
SARG: Line=«1288767194.361 0 10.128.5.121 TCP_DENIED/407 2973 GET http://search.qip.ru/?»
SARG: Record=«%d5%d5%d5%d5%d5%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%d9%d9%d9%d9%d9%d9%d9%d9%d9%d9%d9%d9%d9%d9%d8%d9%d8%d8%d8%d8%d8%d8%d8%d8%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%d8%d8%d9%d9%d8%d8%d8%d8%d9%d8%d9%c3%d8%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%c5%cd%cd%c5%ca%c5%c5%c5%c5%c5%ca%c5%c5%c5%c5%d3%ca%ca%ca%ca%d3%ca%d3%d6%d3%d3%d3%d3%d3%d3%d3%d3%dd%dd%dd%dd%dd NONE/- text/html»
SARG: searching for 'x20'
SARG: getword backtrace:
SARG: 1:/usr/local/bin/sarg [0x804db94]
SARG: 2:/usr/local/bin/sarg [0x804e1b0]
SARG: 3:/usr/local/bin/sarg [0x8051d6a]
SARG: 4:/lib/libc.so.6(__libc_start_main+0xe5) [0xb7eb16a5]
SARG: 5:/usr/local/bin/sarg [0x8049eb1]
SARG: Maybe you have a broken user ID in your /usr/local/squid/var/logs/access.log file



на строчке лога

1288767194.361 0 10.128.5.121 TCP_DENIED/407 2973 GET http://search.qip.ru/? %d5%d5%d5%d5%d5%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%c7%d9%d9%d9%d9%d9%d9%d9%d9%d9%d9%d9%d9
%d9%d9%d8%d9%d8%d8%d8%d8%d8%d8%d8%d8%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%c3%d8%d8%d9%d9%d8%d8%d8%d8%d9%d8%d9%c3%d8%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%cd%c5%cd%
cd%c5%ca%c5%c5%c5%c5%c5%ca%c5%c5%c5%c5%d3%ca%ca%ca%ca%d3%ca%d3%d6%d3%d3%d3%d3%d3%d3%d3%d3%dd%dd%dd%dd%dd NONE/- text/html

★★★

Кстати, у меня тоже приключилась история с саргом. Сначала старая версия сегфолтиься стала, поставил новую - такая же ерунда

SARG: getword backtrace:
SARG: 1:/usr/bin/sarg() [0x406f45]
SARG: 2:/usr/bin/sarg() [0x4070ed]
SARG: 3:/usr/bin/sarg() [0x409ef0]
SARG: 4:/lib/libc.so.6(__libc_start_main+0xfd) [0x7fb2e487ec4d]
SARG: 5:/usr/bin/sarg() [0x402b89]
SARG: Maybe you have a broken date in your /var/log/squid3/access.log file
SARG: getword_atoll loop detected after 0 bytes.
SARG: Line="pplication/x-javascript"
SARG: Record="pplication/x-javascript"
SARG: searching for 'x2f'

И лог парсил, и проверял, запускал с отладкой и т.д. Гуглеж вывел на прошлогодний баг, но вряд ли это он. Думал, может сарг не распарсил и падал, но после экспериментов это не подтвердилось.

uspen ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.