LINUX.ORG.RU
ФорумAdmin

dhcp static binding на несколько vlan


0

1

В данный момент все хосты находятся в одном vlan, ip адреса получают от dhcp сервера, конечно же методом static binding.
!
ip dhcp pool static
origin file tftp://172.17.0.1/static-bindings
!

При разделении сети на несколько vlan не хочу потерять возможность назначать адреса статически. В этом случае есть 2 проблемы:

1) При использовании ip helper-address :

interface Vlan1
ip address 172.17.0.3 255.255.255.0
!
interface Vlan2
ip address 192.168.0.2 255.255.255.0
ip helper-address 172.17.0.3
!

172.17.0.3 - адрес vlan1 интерфейса (dhcp сервера который всегда раздавал адреса)

В данном случае хосты на vlan получают ip адреса из файла static-bindings, но я не знаю как поменять им адрес дефолтного шлюза на правильный.
Ведь у каждого вилана он свой.

2) При сознании пулов для каждого vlan

ip dhcp pool VLAN2
network 192.168.0.0 255.255.255.0
domain-name test
dns-server 172.17.0.1
default-router 192.168.0.1
lease 0 2

В данном случае все хорошо, вот только адреса назначаются динамически,
а те что прописанны в static-bindings работают только для vlan 1.


Ах, да, вопрос: «Как быть?»

n1 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.