LINUX.ORG.RU
ФорумAdmin

squid плохо обрабатывает часть странички


0

0

Всем привет!

Столкнулся с такой проблемой.

Гружу страничку http://rutracker.org/forum/index.php . Без squid грузится нормально. Со squid сайт загружается практически полностью, но курсорчик «крутится», показывая, что сайт загрузился не полностью. Если присмотреться - не грулится элемент «Get Adobe Flash Player» (гружу в opera, плагины отключены, отсюда и такое сообщение). Так может провисеть секунд 30, может минуту. Потом загружается.

Интересен лог.

Когда «висит» видно такое:

1281724497.227    561 127.0.0.1 TCP_MISS/301 647 GET http://adobe.com/images/shared/download_buttons/get_adobe_flash_player.png - DIRECT/192.150.18.117 text/html

А когда наконец-то «пробивает» тишет такое:

1281724617.761    209 127.0.0.1 TCP_MISS/200 3048 GET http://www.adobe.com/images/shared/download_buttons/get_adobe_flash_player.png - DIRECT/192.150.8.60 image/png

То есть перый раз оно определяет get_adobe_flash_player.png как text/html, второй раз - как image/png .

В чем может быть проблема?

★★★★★

Ответ на: комментарий от uspen

Решено. В опере выставил галочки которых не было:

[X] Enable HTTP 1.1 for proxy
[X] Enable start with HTTP 1.1 for proxy

Раньше работало и без них...

Что ж, всем в копилку опыта...

Kroz ★★★★★ ()
Ответ на: комментарий от Kroz

Нет, дело в том как я и сказал: содержимое http://adobe.com/images/shared/download_buttons/get_adobe_flash_player.png

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>301 Moved Permanently</title>
</head><body>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="http://www.adobe.com/images/shared/download_buttons/get_adobe_flash_player.png">here</a>.</p>
</body></html>

uspen ★★★★★ ()
Ответ на: комментарий от spunky

Тут хз, я еще замечаю, что соединения с некоторым ssl сайтами (по https) сквид не обрабатывает - висит «Подключение к localhost»

uspen ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.