LINUX.ORG.RU
ФорумAdmin

Не устанавливается mysql


0

0

Не устанавливается mysql на дебиан. Как это можно исправить? устанавливаю командой aptitude install mysql-server

/etc/apt/sources.list
deb http://ftp.ru.debian.org/debian stable main contrib
deb http://ftp.ru.debian.org/debian testing main contrib
Selecting previously deselected package mysql-client-5.1.
(Reading database ... 26412 files and directories currently installed.)
Unpacking mysql-client-5.1 (from .../mysql-client-5.1_5.1.48-1_amd64.deb) ...
Selecting previously deselected package mysql-server-core-5.1.
Unpacking mysql-server-core-5.1 (from .../mysql-server-core-5.1_5.1.48-1_amd64.deb) ...
Selecting previously deselected package mysql-server-5.1.
Unpacking mysql-server-5.1 (from .../mysql-server-5.1_5.1.48-1_amd64.deb) ...
Stopping MySQL database server: mysqld.
Processing triggers for man-db ...
Setting up mysql-client-5.1 (5.1.48-1) ...
Setting up mysql-server-core-5.1 (5.1.48-1) ...
Setting up mysql-server-5.1 (5.1.48-1) ...
Stopping MySQL database server: mysqld.
100727 12:41:59 [Warning] '--default-character-set' is deprecated and will be removed in a future release. Please use '--character-set-server' instead.
100727 12:41:59 [Note] Plugin 'FEDERATED' is disabled.
100727 12:41:59  InnoDB: Started; log sequence number 0 43655
100727 12:41:59 [ERROR] /usr/sbin/mysqld: unknown option '--skip-bdb'
100727 12:41:59 [ERROR] Aborting

100727 12:41:59  InnoDB: Starting shutdown...
100727 12:42:05  InnoDB: Shutdown completed; log sequence number 0 43655
100727 12:42:05 [Note] /usr/sbin/mysqld: Shutdown complete

Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.1 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 mysql-server-5.1
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up mysql-server-5.1 (5.1.48-1) ...
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.1 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 mysql-server-5.1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

Ответ на: комментарий от anton_jugatsu
apt-cache policy mysql-server
mysql-server:
  Installed: 5.1.48-1
  Candidate: 5.1.48-1
  Version table:
 *** 5.1.48-1 0
        500 http://ftp.ru.debian.org testing/main Packages
        100 /var/lib/dpkg/status
     5.0.51a-24+lenny4 0
        500 http://ftp.ru.debian.org stable/main Packages
blkang ()
Ответ на: комментарий от blkang

я, если честно, так и не понял как мне устранить проблему :)

blkang ()
Ответ на: комментарий от blkang

убрать skip-bdb. Для этого прогрепать конфиги и посмотреть где он остался. И заодно лучше понять почему так получилось. Ты до этого мускул не ставил, конфиги старые не подсовывал, ничего не обновлял?

true_admin ★★★★★ ()
Ответ на: комментарий от true_admin

нет, ничего такого не делал. только возникла необходимость в переустановке, чем я и занялся

blkang ()
Ответ на: комментарий от blkang

браза, просто сделай
cd /etc && grep -R skip-bdb
и поправь найденный файл

hizel ★★★★★ ()
Ответ на: комментарий от hizel

спасибо всем за помощь, но теперь другая проблема при установке) skip-bdb не был найден, я решил сделать romove и установить заново:

aptitude install mysql-server-5.0 
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following NEW packages will be installed:
  mysql-server-5.0
0 packages upgraded, 1 newly installed, 0 to remove and 27 not upgraded.
Need to get 0B/27.3MB of archives. After unpacking 87.0MB will be used.
Writing extended state information... Done
Preconfiguring packages ...
(Reading database ... 26471 files and directories currently installed.)
Unpacking mysql-server-5.0 (from .../mysql-server-5.0_5.0.51a-24+lenny4_amd64.de
b) ...
Aborting downgrade from (at least) 5.1 to 5.0.
dpkg: error processing /var/cache/apt/archives/mysql-server-5.0_5.0.51a-24+lenny
4_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/mysql-server-5.0_5.0.51a-24+lenny4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
ребят, ну очень надо мускул поставить

blkang ()
Ответ на: комментарий от blkang

все сделал. может кому пригодится на будущее:

I search the internet, and somebody said that maybe you should do "rm /var/lib/mysql -rf" before your downgrade from 5.0 to 4.1. I tried, and it worked well.
всем спасибо удачи :)

blkang ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.