LINUX.ORG.RU

Grub hd0


0

0

Конфиг системы:

/dev/sda - 2 раздела с последней версией ntfs (fdisk и cfdisk печатают ошибки, говорят первый раздел поврежден - чушь, всё работает). На первом разделе - загрузочник windows 7, на втором - сама windows 7. (загрузочный)

/dev/sdb - ntfs, 1 раздел, файлопомойка
/dev/sdc1 - ntfs, файлопомойка

/dev/sdc2 - ext2 /boot с GRUB (загрузочный)
/dev/sdc3 - swap2
/dev/sdc4 - ext4 /home
/dev/sdc5 - ext4 /

Материнка ASUS. sda - IDE, sdb,sdc - SATA (не рейд). Загрузка идет с жесткого диска «sdc».

ArchLinux, свежая установка, дефолтный grub.

Проблема:

При установке гроба он прописывает загрузку с hd(2,1) для Linux и добавляет закомменченную секцию загрузки windows с hd(0,0).

Во-первых, во время установки гроб переставляет маркер загрузки на /dev/sdc1 (где у нас ntfs-файлопомойка). Ладно, заменяем назад на /dev/sdc2.

Однако ничего при этом не грузится.

Опытным путем было установлено, что если поправить hd(2,1) (что в моем понимании и должно соответствовать /dev/sdc2) на hd(0,1) - то всё работает.

Вопрос - каким образом последний диск в списке ВНЕЗАПНО становится первым? Под каким номером теперь должен появиться раздел с Windows (sda), и по какому принципу происходят замены буковок?

Спасибо :)

★★★☆☆

странно, что IDE-диск у вас обозначается sd*#, по идее должен обозначаться hd*#. Скорее всего, отсюда и последовательность - sata-диски будут идти первыми в именовании, а IDE-диски - потом.

gserg ★★ ()

1. Гроб в похоронном бюро, усвой это

2.

stevejobs

/dev/sdc1 - ntfs, файлопомойка /dev/sdc2 - ext2 /boot с GRUB (загрузочный) /dev/sdc3 - swap2 /dev/sdc4 - ext4 /home /dev/sdc5 - ext4 /

я один вижу здесь некое несоответствие?О_О

novitchok ★★★★★ ()
Ответ на: комментарий от novitchok

> я один вижу здесь некое несоответствие?О_О

какое?

stevejobs ★★★☆☆ ()
Ответ на: комментарий от novitchok

> такое.

а что смущает? количество?
sdc1-3 - primary, 4-5 - extended

stevejobs ★★★☆☆ ()
Ответ на: комментарий от novitchok

ой, прости.

sdc5 и sdc6 конечно же. sdc4 - extended и его не видно

stevejobs ★★★☆☆ ()
Ответ на: комментарий от stevejobs

во, теперь ничего не смущает))), а то четыре первичных и один логический - перебор однако;)

novitchok ★★★★★ ()
Ответ на: комментарий от gserg

>странно, что IDE-диск у вас обозначается sd*#

Очнись, так уже давно заведено. Если не ошибаюсь, с тех, когда в ядре переходили на libata

xscrew ★★ ()

А что /boot/grub/device.map содержит?

p.s. Речь о каком grub`е, 1-м или 2-м?

Attila ()

map hd0 hd1
map hd1 hd0
нет чего-то подобного ?

kostik87 ★★★★★ ()

Проблема решилась.

1) Вначале буквы дисков скакали
2) Перепроверка sda с помощью Windows 7 вылечила partition table (исчезли ошибки в Linux).
3) После чего «прыгающий» диск с линуксом стал называться sdb, что не соответствует порядку включения жестких дисков в материнку и индикаторам в BIOS, зато название sdb не меняется.
4) Для закрепления результата перевел fstab и grub menu.lst на определение дисков по меткам (label).

Спасибо за советы :)

stevejobs ★★★☆☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.