LINUX.ORG.RU
решено ФорумAdmin

Обновил Debian Etch 4.0 до Lenny


0

0

Обновил Debian Etch 4.0 до Lenny и теперь у меня в панели Plesk при нажатии проверить обновления вот такая ошибка " Невозможно определить ход процесса установки: Failed to retrieve the version of your operating system from the file /etc/debian_version" ?
в файле /etc/debian_version «squeeze/sid»
что мне нужно теперь подправить, что бы работало дальше нормально?


Unable to upgrade. You have 9.3.0 version installed,
but upgrader is incompatible with this version.
To install new Plesk copy, please move '/opt/psa'
to another place manually.
dpkg: error processing /var/cache/apt/archives/psa_9.3.0-debian5.0.build93091230.10_amd64.deb (--unpack):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/psa_9.3.0-debian5.0.build93091230.10_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done


вот что пишет при aptitude upgrade
хотя сама панель Plesk работает, но не обновляется, что то видать не так обновилось, подскажите пожалуйста, как подправить?
спасибо.

fsn ()

Re: Обновил Debian Etch 4.0 до Lenny

Какой инструкцией пользовался при обновлении?

aydar ★★★★★ ()

у debian lenny должно быть на текущий момент:
# cat /etc/debian_version
5.0.4

а то что у вас, это sid :]

hizel ★★★★★ ()
Ответ на: комментарий от markevichus

aptitude full-upgrade
вот этим, ну там в ссылке всё написано, я так и делал.

fsn ()
Ответ на: комментарий от sysmouse

вот что скрипт при опросе системы выдаёт
Операционная система:   Linux 2.6.31
Версия PHP:   5.2.6-1+lenny6
Версия MySQL:   5.0.51a-24+lenny3-log MySQLi

fsn ()
Ответ на: комментарий от hizel

o084:~# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 4.0 (etch)
Release: 4.0
Codename: etch


классно, теперь думаю лучше снести всё и установить Lenny с нуля ?

fsn ()
Ответ на: комментарий от hizel

ясно, спасибо всем за содействие, делаю резервную копию, и буду по новой переустанавливать всё.

fsn ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.