LINUX.ORG.RU
ФорумAdmin

linux роутер (ubuntu 9,10)


0

0

здравствуйте. у меня такая проблема: есть только одна сетевая карта. сделал следующие сетевые настройки: eth0 Link encap:Ethernet HWaddr 00:30:4f:17:36:46 inet addr:193.219.88.10 Bcast:193.219.88.15 Mask:255.255.255.240 inet6 addr: fe80::230:4fff:fe17:3646/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:13179 errors:0 dropped:0 overruns:0 frame:0 TX packets:188 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:1695849 (1.6 MB) TX bytes:22254 (22.2 KB) Interrupt:11 Base address:0xd000

eth0:0 Link encap:Ethernet HWaddr 00:30:4f:17:36:46 inet addr:192.168.2.1 Bcast:192.168.2.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 Interrupt:11 Base address:0xd000

lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:4 errors:0 dropped:0 overruns:0 frame:0 TX packets:4 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:240 (240.0 B) TX bytes:240 (240.0 B) но роутер почему-то не роутит.. в чем проблема? что еще нужно сделать?

192.168.2.1 пингуется из локальной сети?

ip forwarding в ядре включили?

iptables настроили?

edigaryev ★★★★★ ()
Ответ на: комментарий от edigaryev

и 192.168.2.1 и 193.219.88.10 пингуются. /sbin/iptables -P FORWARD ACCEPT делал. с iptables что-то делал, но не уверен что правильно.

pavliuccio ()
Ответ на: комментарий от pavliuccio

я просто первый раз делаю такую штуку и в этом деле совсем новичок.

pavliuccio ()
Ответ на: комментарий от edigaryev

bash: /proc/sys/net/ipv4/ip_forward: no such file or directory

# Generated by iptables-save v1.4.4 on Mon Jan 18 09:13:27 2010 *filter :INPUT ACCEPT [1808:2214641] :FORWARD ACCEPT [0:0] :OUTPUT ACCEPT [330:27559] COMMIT # Completed on Mon Jan 18 09:13:27 2010

pavliuccio ()
Ответ на: комментарий от pavliuccio

А так:

sysctl -w net.ipv4.ip_forward="1"
? Затем:
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
У вас динамический/статический IP?

edigaryev ★★★★★ ()
Ответ на: комментарий от edigaryev

работает!!! :) большое спасибо за реальную помощь! я неделю уже сидел. все ip статические.

pavliuccio ()
Ответ на: комментарий от pavliuccio

видимо рановато я порадовался. после рестарта опять не работает. начинает работать после введения этой строки: iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE как ее зафиксировать?

pavliuccio ()
Ответ на: комментарий от pavliuccio

/etc/init.d/iptables save или iptables-save > /etc/sysconfig/iptables_params и при загрузки в /etc/rc.local прописать строчку
/sbin/iprables-restore /etc/sysconfig/iptables_params

pavel38 ()
Ответ на: комментарий от pavel38

bash: /etc/init.d/iptables: No such file or directory bash: /etc/sysconfig/iptables_params: No such file or directoryNo such file or directory

pavliuccio ()
Ответ на: комментарий от pavliuccio
iptables-save > /etc/firewall-rules

Затем в /etc/rc.local добавить:

iptables-restore /etc/firewall-rules

edigaryev ★★★★★ ()
Ответ на: комментарий от edigaryev

bash: /etc/firewall-rules: permission denied не понимаю почему так. я через sudo делал..

pavliuccio ()
Ответ на: комментарий от edigaryev

успешно выполнил вышеуказанные команды. но все по-прежнему после рестарта не работает.

pavliuccio ()
Ответ на: комментарий от pavliuccio
sysctl net.ipv4.ip_forward

Что показывает?

Если 0, тогда нужно добавить в файл /etc/sysctl.conf строчку:

net.ipv4.ip_forward = 1
Если там будет подобная, но с 0, тогда можно просто изменить 0 на 1.

edigaryev ★★★★★ ()
Ответ на: комментарий от edigaryev

показывает: net.ipv4.ip_forward = 1 в файле /etc/sysctl.conf абсолютно все строчки закомментированны. (не знаю или это имеет значение).

pavliuccio ()
Ответ на: комментарий от pavliuccio

Нужно добавить в /etc/sysctl.conf то что я сказал. После рестарта должно показывать 1.

edigaryev ★★★★★ ()
Ответ на: комментарий от edigaryev

вписал, теперь показывает 1. но все равно работает только после команды: iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

pavliuccio ()
Ответ на: комментарий от edigaryev

#!/bin/sh -e # # rc.local # # This script is executed at the end of each multiuser runlevel. # Make sure that the script will «exit 0» on success or any other # value on error. # # In order to enable or disable this script just change the execution # bits. # # By default this script does nothing.

exit 0

firewall-rules: # Generated by iptables-save v1.4.4 on Wed Jan 20 10:19:39 2010 *nat :PREROUTING ACCEPT [50989:4058272] :POSTROUTING ACCEPT [0:0] :OUTPUT ACCEPT [28:1714] -A POSTROUTING -o eth0 -j MASQUERADE COMMIT # Completed on Wed Jan 20 10:19:39 2010 # Generated by iptables-save v1.4.4 on Wed Jan 20 10:19:39 2010 *filter :INPUT ACCEPT [1214:160984] :FORWARD ACCEPT [687464:367824355] :OUTPUT ACCEPT [319:29522] COMMIT # Completed on Wed Jan 20 10:19:39 2010

pavliuccio ()
Ответ на: комментарий от edigaryev

извиняюсь, не вписал.
сейчас вписал, сделал рестарт и все работает!
большое спасибо за помощь!!!

pavliuccio ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.