LINUX.ORG.RU
ФорумAdmin

httpd и порты, проблема при запуске


0

0

Такая проблема - есть три name-based виртуальных хоста, в httpd.conf, соотвественно, три директивы Listen смотрят на три порта, дабы хосты поднялись. Только вот демон отказывается стартовать при любых значениях портов, кроме :80, :8080, :443. Стоит написать, например, вторым Listen 81, всё, не стартует. error_log чистый, проверка синтаксиса ровная, порты никто не занимает. Вчера, в течении дня машину не перезагружал, ковырялся с fastcgi-модулем, и к вечеру решил попробовать выставить искомые 80, 81, 82. демон поднялся, но сегодня с утра опять та же фигня, облом при старте. мож кто сталкивался?

Ответ на: Re: httpd и порты, проблема при запуске от polozad

Re: httpd и порты, проблема при запуске

> centos 5. Действительно, SELinux вырубить надо было. Спасибо. Вчера я его ложил временно, потому всё и поднялось. Сегодня вырубил насмерть.

Врубай обратно. У меня доклад на LVEE предвидится "настройка и использование SELinux", а ты мне тут говоришь "настроил отключением" :)

[code]
semanage port --add -t http_port_t -p tcp 81-83
[/code]

Slavaz ★★★★★ ()
Ответ на: Re: httpd и порты, проблема при запуске от Slavaz

Re: httpd и порты, проблема при запуске

> Врубай обратно. У меня доклад на LVEE предвидится "настройка и использование SELinux", а ты мне тут говоришь "настроил отключением" :)

Не поделитесь простым и понятным мануалом по SELinux? (Можно на английском)

bvvv ()
Ответ на: Re: httpd и порты, проблема при запуске от bvvv

Re: httpd и порты, проблема при запуске

В догонку: http://tanso.net/selinux/
Но там описано использование audit2allow - это не совсем верно для настройки. Это больше хелпер при разработке своего собственного модуля.

В остальном ничего.

Slavaz ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.