LINUX.ORG.RU
ФорумAdmin

OSPF: связка Quagga - D-Link 3627


0

0

Добрый день, Уважаемые! В наличие имеется: Роутер «А»: FreeBSD, quagga (BGP+OSPF); Роутер «В»: D-Link 3628. За ним находиться сеть NET-1. Между собой «А» и «В» соединены в сети NET-2 и обмениваются маршрутной информацией по протоколу OSPF.

Также в сети NET-2 есть роутер «С», за которым расположена сеть NET-3. Роутер поддерживает протокол BGP и обменивается маршрутной информацией с роутером «А».

Задача: Сконфигурировать роутеры «А» и «В» таким образом, чтобы трафик от сетей NET-1,NET-3 проходил напрямую через роутеры «В» и «С», минуя роутер «А». Для наглядной картины нарисовал схему: http://www.isen.ru/tmp/a2.png

С настройкой BGP все получилось, указав в конфиге команду "next-hop ip-адрес роутера «B»", трафик из сети NET-3 действительно маршрутизируется, минуя роутер «А». Но исходящий трафик сети NET-1 все равно ходит через роутер «А». В таблице маршрутизации роутера «В» сеть NET-3 указана за роутером «А». Вот что сейчас получается: http://www.isen.ru/tmp/a1.png

Помогите пожалуйста справиться с задачей!

Re: OSPF: связка Quagga - D-Link 3627

на роутере А нужно настроить редистрибьюцию OSPF в BGP и BGP в OSPF, и, если среда широковещательная, и нет комманды net-hop-self, то в адреса next-hop-ов будут меняться на ближайшие.

chocholl ★★ ()
Ответ на: Re: OSPF: связка Quagga - D-Link 3627 от chocholl

Re: OSPF: связка Quagga - D-Link 3627

Спасибо за ответ. Редистрибуция из BGP в OSPF настроена. В обратную сторону не могу настроить из политических соображений компании.

Вот конфиги роутера "А"
bgpd.conf:
!
log file /var/log/bgpd.log
!
router bgp 64001
bgp router-id 10.0.0.2
network 10.0.1.0/24
neighbor 10.0.0.3 remote-as 64002
neighbor 10.0.0.3 route-map net-out out
!
ip prefix-list net-local seq 10 permit 10.0.1.0/24
!
route-map net-out permit 10
match ip address prefix-list net-local
set ip next-hop 10.0.0.1
!
line vty
!

ospfd.conf:
!
log file /var/log/ospfd.log
!
interface fxp0
!
interface lo0
!
router ospf
ospf router-id 0.0.0.2
redistribute bgp
network 10.0.0.0/24 area 0.0.0.1
!
line vty
!

zebra.conf:
!
hostname bgp-router
password 123
enable password 123
log file /var/log/zebra.log
!
interface fxp0
multicast
!
interface lo0
!
ip route 10.0.1.0/24 10.0.0.1
!
ip forwarding
ipv6 forwarding
!
line vty
!

r_cannibal ()
Ответ на: Re: OSPF: связка Quagga - D-Link 3627 от r_cannibal

Re: OSPF: связка Quagga - D-Link 3627

в router bgp 64001 нет редистрибьюции, т.е. из bgp в ospf есть.
а обратно нет, вот это и нужно сделать.
и route-map уберите, в ethernet среде он и так поменяет netx-hop.

chocholl ★★ ()
Ответ на: Re: OSPF: связка Quagga - D-Link 3627 от chocholl

Re: OSPF: связка Quagga - D-Link 3627

Попробовал добавить редистрибьюцию, т.е. из ospf в bgp. Убрал route-map. Теперь маршрутизация и в сеть NET-1 идет через роутер "А".

r_cannibal ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.