LINUX.ORG.RU
ФорумAdmin

config Kernel FreeBSD 4.7


0

0

Всем доброе время суток, я пытаюсь пересобрать ядро, но сказывается нехватка опыта ну и конешно же "родимая криворукость". Вот уже пошёл третий день, перелопитил кучу доков, единственное чего добился так это то, что компиляция проходит без ошибок, но после "make install" и "reboot" полученные ядра не загружаются :-[.

Большущая прозьба HELP.

#dmesg

Copyright (c) 1992-2002 The FreeBSD Project. Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994 The Regents of the University of California. All rights reserved. FreeBSD 4.7-RELEASE #0: Wed Oct 9 15:08:34 GMT 2002 root@builder.freebsdmall.com:/usr/obj/usr/src/sys/GENERIC

Timecounter "i8254" frequency 1193182 Hz

CPU: Pentium III/Pentium III Xeon/Celeron (598.47-MHz 686-class CPU)

Origin = "GenuineIntel" Id = 0x683 Stepping = 3

Features=0x387f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,P AT,PSE36,PN,MMX,FXSR,SSE>

real memory = 133955584 (130816K bytes)

avail memory = 125181952 (122248K bytes)

Pentium Pro MTRR support enabled

md0: Malloc disk

Using $PIR table, 11 entries at 0xc00f2fb0

npx0: <math processor> on motherboard

npx0: INT 16 interface

pcib0: <Host to PCI bridge> on motherboard

pci0: <PCI bus> on pcib0

pcib1: <PCI to PCI bridge (vendor=8086 device=250f)> at device 1.0 on pci0

pci1: <PCI bus> on pcib1

pci1: <ATI Mach64-GM graphics accelerator> at 0.0 irq 11

pcib2: <Intel 82801AA (ICH) Hub to PCI bridge> at device 30.0 on pci0

pci2: <PCI bus> on pcib2

rl0: <RealTek 8139 10/100BaseTX> port 0xd400-0xd4ff mem

0xfeaff800-0xfeaff8ff irq 11 at device 8.0 on pci2

rl0: Ethernet address: 00:c0:df:0f:e9:51

miibus0: <MII bus> on rl0

rlphy0: <RealTek internal media interface> on miibus0

rlphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto

pci2: <unknown card> (vendor=0x1274, dev=0x1371) at 9.0 irq 10

adv0: <AdvanSys ASC3030/50 SCSI controller> port 0xd800-0xd8ff mem

0xfeaffc00-0xfeaffcff irq 9 at device 10.0 on pci2

adv0: Warning EEPROM Checksum mismatch. Using default device parameters

adv0: AdvanSys SCSI Host Adapter, SCSI ID 7, queue depth 16

pci2: <unknown card> (vendor=0x14f1, dev=0x2013) at 11.0 irq 11

isab0: <Intel 82801AA (ICH) PCI to LPC bridge> at device 31.0 on pci0

isa0: <ISA bus> on isab0

atapci0: <Intel ICH ATA66 controller> port 0xffa0-0xffaf at device 31.1 on pci0

ata0: at 0x1f0 irq 14 on atapci0

ata1: at 0x170 irq 15 on atapci0

uhci0: <Intel 82801AA (ICH) USB controller> port 0xef80-0xef9f irq 11 at device 31.2 on pci0

usb0: <Intel 82801AA (ICH) USB controller> on uhci0

usb0: USB revision 1.0

uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1

uhub0: 2 ports with 2 removable, self powered

pci0: <unknown card> (vendor=0x8086, dev=0x2413) at 31.3 irq 10

orm0: <Option ROM> at iomem 0xc0000-0xc97ff on isa0

fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0

fdc0: FIFO enabled, 8 bytes threshold

fd0: <1440-KB 3.5" drive> on fdc0 drive 0

atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0

atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0 kbd0 at atkbd0

psm0: <PS/2 Mouse> irq 12 on atkbdc0

psm0: model Generic PS/2 mouse, device ID 0

vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0

sc0: <System console> at flags 0x100 on isa0

sc0: VGA <16 virtual consoles, flags=0x300>

sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0

sio0: type 16550A

sio1 at port 0x2f8-0x2ff irq 3 on isa0

sio1: type 16550A

ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0

ppc0: Generic chipset (EPP/NIBBLE) in COMPATIBLE mode

plip0: <PLIP network interface> on ppbus0

lpt0: <Printer> on ppbus0

lpt0: Interrupt-driven port

ppi0: <Parallel I/O> on ppbus0

ad0: 19574MB <IBM-DPTA-372050> [39770/16/63] at ata0-master UDMA66

acd0: CDROM <TOSHIBA CD-ROM XM-6702B> at ata1-slave PIO4

Waiting 15 seconds for SCSI devices to settle

Mounting root from ufs:ad0s4a

cd0 at adv0 bus 0 target 3 lun 0

cd0: <YAMAHA CRW8824S 1.00> Removable CD-ROM SCSI-2 device

cd0: 10.000MB/s transfers (10.000MHz, offset 15)

cd0: Attempt to query device size failed: NOT READY, Medium not present - tray closed

----------#

Ето набор железок для более полной инфы, в инет вхожу через "PPTP" ADSL модем ALCATEL, причём в Slackware8.1 всё это работает "на ура". Может кто набросает kernel.config опираясь на эти данные и на свой ОПЫТ, не дайте сдохнуть возле компа.

email : evganyb@bezeqint.net

Обязательно отблагадарю , например могу выкачать чё нодо с инета записать на CD и выслать. Извините что так долго и много.

с уважением Евгений.

anonymous

Re: config Kernel FreeBSD 4.7

А в чем проблема, собственно? Все ж вроде нормально? А самодельные ядра - вообще - грузятся? Или даже booting... не появляется? Напиши подробнее...

А вообще... может - ну его нафиг? Оставь Slackware как шлюз. У FreeBSD c PPTP+Alcatel почему-то проблемы постоянно, единственное, что у меня завелось - DHCP_SPOOF...

А твой провайдер никак по другому доступ не предоставляет? PPPoE, например? Вообще - где это все происходит?

Если все же захочешь с FreeBSD бороться - пиши timur_at_europe_dot_com.

BaT ★★★★★ ()

Re: config Kernel FreeBSD 4.7

Чего-то меня на "вообще" пробило :>

Я есть плёхо гаварить парюски....

BaT ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.