LINUX.ORG.RU
ФорумAdmin

nfs-шара монтируется, а mount ее не показывает


0

0

NFS-сервер: Gentoo
NFS-клиент: Ubuntu 7.10

При включении клиента доступ к шаре есть (все файлы открываются), а mount ее не показывает. При перемонтировании - показывает. Что такое?

gentoo-server $ grep data_ /etc/exports
/data_200/ 192.168.0.0/255.255.0.0(async,no_subtree_check,ro)
/data_400/ 192.168.0.0/255.255.0.0(async,no_subtree_check,ro)

ubuntu-desktop $ grep nfs /etc/fstab
192.168.1.100:/data_200 /data_200 nfs ro,rsize=8192,wsize=8192,timeo=14,intr 0 0
192.168.1.100:/data_400 /data_400 nfs ro,rsize=8192,wsize=8192,timeo=14,intr 0 0

Re: nfs-шара монтируется, а mount ее не показывает

>а mount ее не показывает.

А что в этом случае показывает "cat /proc/mounts"?

mky ★★★★★ ()

Re: nfs-шара монтируется, а mount ее не показывает

А там все правильно))

ubuntu-desktop $ cat /proc/mounts | grep data_
192.168.1.100:/data_200 /data_200 nfs ro,vers=3,rsize=8192,wsize=8192,hard,intr,proto=tcp,timeo=14,retrans=2,sec=sys,
addr=192.168.1.100 0 0
192.168.1.100:/data_400 /data_400 nfs ro,vers=3,rsize=8192,wsize=8192,hard,intr,proto=tcp,timeo=14,retrans=2,sec=sys,
addr=192.168.1.100 0 0

henturis ()

Re: nfs-шара монтируется, а mount ее не показывает

Я не специалист по Ubuntu, но если покопаться в google, то вроде это типичный bug (не пишется в /etc/mtab монтирование NFS при заргрузке системы). Одни советуют сделать /etc/mtab ссылкой на /proc/mounts, а в других местах советуется это не делать.

ИМХО, может проще поправить стартовый скрипт, в котором вызывается mount -a -t nfs

mky ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.