LINUX.ORG.RU
ФорумAdmin

сетевые, свитчи и т.д.


0

0

Ситуация следующая: имеется линух, он играет роль шлюза. На нем установленны 2 сетевые. Соответственно одна смотрит наружу, а одна идет во внутренний 100 мегабитный свитч. Одна из сетевых 10-мегабитная (rtl8029) а вторая 100-мегабитная(Acorp с чипом rtl8139c). Если сделать так, что 100-мегабитка смотрит наружу, а в свитч воткнута 10-мегабитка, то все нормально работает. Если же сделать наоборот, что вобщем-то более логично, так как понятно что в локалке хочется иметь скорость больше, то начинаются коллизии - теряется при пинге около половины пакетов. При этом замена 100-мегабитной карты на себеподобную ничего не меняет. Далее, был поставлен вместо свича - 10-мегабитный хабчик. И что вы думаете? заработало. и со 100-мегабитной и с 10-мегабитной карточкой, смотрящими внутрь локалки.
Расскажите, в чем может быть трабла?
Настройки в линухе тут похоже не при чем.
на свиче порты меняли - все остальные машины, которые в него воткнуты, вроде бы работают нормально.
Заранее спасибо.

anonymous

Re: сетевые, свитчи и т.д.

А насколько загружен твой наружный канал (на 10 Мбитах)?

Octopus ()

Re: сетевые, свитчи и т.д.

Была такая проблема 10 работала а 100 нет рыл везде но оказалось проще заменил сетевой кабель требование к нему больше попробуй перебить головы

anonymous ()

Re: сетевые, свитчи и т.д.

Была другая ситуация, то же понять не смог в чем дело switch Catalyst 3548 eth0 (Rtl8029) 192.168.1.1 default gw 192.168.1.2(Сisco router)=10Mb/s eth1 (Rtl8139) 192.168.1.3=100Mb/s поднимаю IPX на eth1( в сети имеется Novell 10Mb/s адаптер на нем) Получается коллизии, по IPX сеть грузится так, что по всему зданию не работает...IP ходит нормально вроде. перебиваю IPX adress на eth0-все работает нормально...Меняю местами адаптеры eth0 и eth1 коллизии есть. значит что то анамальное....Не объясните в чем дело? В принципе мне и так хорошо, но вопрос остался вопросом. :(

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.