LINUX.ORG.RU
ФорумAdmin

Под Gentoo 2007.0 не заводится PPPoE сессия


0

0

После долгого мозгодолбления с установкой Cxacru для моего момеда ADSL Линия наконец-то работает. Толку, впрочем от нее ноль.
pppoe-start не может установить соединение
Привожу кусок лога:

---система грузится---
Jun 28 15:30:31 ptihost usbcore: registered new interface driver cxacru
Jun 28 15:30:31 ptihost cxacru 2-1:1.0: found firmware cxacru-fw.bin
Jun 28 15:30:31 ptihost cxacru 2-1:1.0: found firmware cxacru-bp.bin
Jun 28 15:30:31 ptihost cxacru 2-1:1.0: found firmware cxacru-cf.bin
Jun 28 15:30:35 ptihost init: Entering runlevel: 3
Jun 28 15:30:43 ptihost ATM dev 0: ADSL line: attempting to activate
Jun 28 15:30:48 ptihost ATM dev 0: ADSL line: down
Jun 28 15:30:53 ptihost ATM dev 0: ADSL line: attempting to activate
Jun 28 15:30:58 ptihost ATM dev 0: ADSL line: channel analysis
Jun 28 15:31:03 ptihost ATM dev 0: ADSL line: up (2048 kb/s down | 512 kb/s up)
---выполняю команду br2684ctl с параметрами---
Jun 28 15:31:40 ptihost br2684ctl[4098]: Interface "nas0" created sucessfully
Jun 28 15:31:40 ptihost br2684ctl[4098]: Communicating over ATM 0.1.50, encapsulation: LLC
Jun 28 15:31:40 ptihost br2684ctl[4098]: Interface configured
Jun 28 15:31:40 ptihost br2684ctl[4100]: RFC 1483/2684 bridge daemon started
Jun 28 15:31:40 ptihost udev-net.sh: /etc/init.d/net.nas0: does not exist or is not executable
---делаю ifconfig nas0 up ---
---Запускаю (настроено заранее) pppoe-start
Jun 28 15:36:12 ptihost PPP generic driver version 2.4.2
Jun 28 15:36:17 ptihost pppd[8239]: pppd 2.4.4 started by root, uid 0
Jun 28 15:36:17 ptihost pppd[8239]: Couldn't set tty to PPP discipline: Invalid argument
Jun 28 15:36:17 ptihost pppoe[8240]: PADS: Service-Name: ''
Jun 28 15:36:17 ptihost pppoe[8240]: PPP session is 9571 (0x2563)
Jun 28 15:36:17 ptihost pppoe[8240]: read (asyncReadFromPPP): Session 9571: Input/output error
Jun 28 15:36:17 ptihost pppoe[8240]: Sent PADT
Jun 28 15:36:18 ptihost pppd[8239]: Exit.
Jun 28 15:36:18 ptihost pppoe-connect: PPPoE connection lost; attempting re-connection.
Jun 28 15:36:28 ptihost pppoe-connect: PPPoE connection lost; attempting re-connection.
Jun 28 15:36:33 ptihost pppd[8307]: pppd 2.4.4 started by root, uid 0
Jun 28 15:36:33 ptihost pppd[8307]: Couldn't set tty to PPP discipline: Invalid argument
Jun 28 15:36:34 ptihost pppoe[8308]: PADS: Service-Name: ''
Jun 28 15:36:34 ptihost pppoe[8308]: PPP session is 4334 (0x10ee)
Jun 28 15:36:34 ptihost pppoe[8308]: read (asyncReadFromPPP): Session 4334: Input/output error
Jun 28 15:36:34 ptihost pppoe[8308]: Sent PADT

и так много раз

И все. ifconfig показал что по nas0 Были Rx и Tx пакетов, но коннекта нету....

Re: Под Gentoo 2007.0 не заводится PPPoE сессия

Jun 28 15:36:17 ptihost pppd[8239]: Couldn't set tty to PPP discipline: Invalid argument

Может проблема в этом?

ivanich ★★ ()

Re: Под Gentoo 2007.0 не заводится PPPoE сессия

Make sure that you have a kernel with support for pppd, including the ppp modules for the various line disciplines. If you get error messages in syslog along the lines of: modprobe: modprobe: Can't locate module tty-ldisc-3 pppd[10163]: Couldn't set tty to PPP discipline: Invalid argument then you know that you need to recompile your kernel with support for ppp_async, pppoe, and pppox. If you have this support via modules, make sure the modules are loaded or that your kernel support autoloading of modules.

ivanich ★★ ()

Re: Под Gentoo 2007.0 не заводится PPPoE сессия

Удали нахрен все ссылки и описания интерфейса nas0 из /etc/conf.d/net, проще поднимать руками, чем этот гимор выдерживать.

Хинт - "из-за непостоянного промежутка времени на поднятие линка до DSLAM нельзя точно предсказать когда запускать обвязку br* и pppd с pppoe". Поэтому проще написать скрипт, который будет делать всё что нужно на гарантированно поднявшейся линии (man dmesg), и пускать его руками после загрузки машины.

br2864_* в /etc/conf.d/net в сочетании с udev'ом я осилить так и не смог - уж больно там всё через жопу и друг у друга верёвку вырывает.

Вариант 2 - найди 30 баков и купи LAN-момед.

Gharik ()
Ответ на: Re: Под Gentoo 2007.0 не заводится PPPoE сессия от Unclewaighty

Re: Под Gentoo 2007.0 не заводится PPPoE сессия

ура! все заработало!
оказывается, этот сцуко не видел логин и пароль из секретов
из конф.д - все увидел
кстати, запихнуть все в конфд (и не юзать) рп-пппое - вполне реально, я почитал вики и все сделал через конф.д
удев в пролете (с брктлчто-тотамом)

спасибо всем

Unclewaighty ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.