LINUX.ORG.RU
ФорумAdmin

Не получается связать Apache & PHP


0

0

Добрый день. Пытаюсь их связать. Я конечно все понимаю, что вопрос наитупейший, но у меня ничего не получается... Помогите плизззз.. )) Скачал последнюю версию PHP и Apache. Делаю для PHP ./configure --with-mysql --with-apache=../apache_1.3.23rusPL30 --with-mod_charset make make install Делаю для Apacha ./configure --activate-module=src/modules/php4/libphp4.a make make install Все компилируется без ошибок... Смотрю Httpd -l модуль mod_php4 есть. В httpd.conf добавляю: AddType application/x-httpd-php .php Вроде все как правильно, как по докам, но в итоге при запуске PHP в Эксполере выдается запрос на сохранение этого файла.

В чем я тут не прав ???

anonymous

Re: Не получается связать Apache & PHP

Hi ! У меня вроде все так же само и работает А что apache в логах пишет на счет запуска php-скриптов ?

anonymous ()

Re: Не получается связать Apache & PHP

Перечисли плз полный список команд, которые ты делал.

Вообще то лучше пхп привязывать через DSO:

./configure --with-apxs=/usr/local/bin/apxs

Какая версия пхп, апач?

дай всё что связано с пхп в конфиге апачи.

Там ещё должно быть:

Если компилил через DSO, то:
LoadModule php4_module libexec/libphp4.so
AddModule mod_php4.c

И строчка для добавления поддержки расширений .пхп:
AddType application/x-httpd-php .php .phtml .php3 .php4

Ну и разумеется нужно директори индекс выставить прально:
DirectoryIndex index.php index.phtml index.html index.htm index.shtml

если что, пиши на мыло: marat@nihol.com

unReal ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.