LINUX.ORG.RU
ФорумAdmin

Проблемы с BIND


0

0

Фабула вопроса: не могу правильно настроить BIND.

Исходное: ========= 1) ОС Linux Mandrake 10.0 Off 2) BIND ver. 9.2.4 3) Сетевая среда: локальная на TCP/IP с выходом в инет через маршрутизатор на W2003. 4)Мой IP в локалке 192.168.0.250 5)IP маршрутизатора/DNS-сервера локалки 192.168.0.1

Возникла необходимость настроить name-based виртуальные хосты на Апаче, установленном на этом самом Мандрейке. Хостами должен свободно управлять я сам. Для этого понадобилось установить и настроить BIND. Мысль была такая: поставить BIND и создать в нем зону, которая будет обслуживать мой Апач, доступ к адресам в локалке и в инете организовать, не прописывая альтернативный DNS-сервер, а используя тот же самый BIND, который будет прописам первым и единственным DNS-сервером для моей машины. В результате настройки имею следующее: 1) Зона, предназначенная для Апача, обрабатывается полностью корректно. 2) Разрешение имени нашего локально-сетевого сервера происходит. 3) Разрешение имен внешних серверов не происходит. Т.о., я не вижу инета (что, разумеется, не касается случаев прямого обращения по IP).

Я поломал весь ум, но найти ошибку так и не смог.

Приведу конфиги BIND'а:

1) named.boot ============= directory /var/named primary 127.in-addr.arpa local.rev primary apachehosts hosting.prim ;зона виртуальных хостов cache . named.ca forwarders 192.168.0.1 slave

Комментарий: ============ Свой BIND я настраиваю не итерирующим, а рекурсивным. При попытке сделать его итерирующим имя нашего локально-сетевого сервера перестает разрешаться.

2) named.conf ============= options { directory "/etc/named"; allow-query {127.0.0.1; 192.168.0.250}; };

zone "." { type hint; file "named.ca"; };

zone "127.in-addr.arpa" { type master; file "local.rev"; };

zone "apachehosts" { type master; file "hosting.prim"; };

3) named.ca =========== . 3600000 IN IS localnet.net. localnet.net 3600000 IN A 192.168.0.1

Файл local.rev я приводить не буду, потому-что он самоочевиден. Я серьезно и основательно несколько дней пытаюсь найти ошибку во всем это, но без особого успеха.

Плз, хелп.

anonymous

Re: Проблемы с BIND

сложно конечно понять, что-то из вышеприведеного, но я так понял, что у тебя не работает резолвинг имён отличных от обслуживаемых твоим нэймсервером. что нужно сделать? 1. проверить свой фаервол на возможность блокирования запросов на 53 порт 2. Настроить логгинг в Bind и отслеживать.

BusTeR ()

Re: Проблемы с BIND

> named.ca =========== . 3600000 IN IS localnet.net. localnet.net 3600000 IN A 192.168.0.1

Зачем ты так тут сделал? Чем мешал обычный вариант файла корневых серверов?

Попробуй еще через опцию forwarders указать главный ДНС forwarders {192.168.0.1};

gruy ★★★★★ ()
Ответ на: Re: Проблемы с BIND от gruy

Re: Проблемы с BIND

Я правил файл корневых серверов потому, что для меня в роли корневого сервера выступает главный DNS-сервер локалки - доступа к другим серверам я просто не имею, они закрыты на сервере.

Ну а указать форвардер через опцию попробую...

anonymous ()
Ответ на: Re: Проблемы с BIND от anonymous

Re: Проблемы с BIND

>Ну а указать форвардер через опцию попробую...

Да, это помогло - BIND заработал.
===
После этого я убрал из named.boot строки:
forwarders 192.168.0.1
slave
этим вроде бы переводя BIND в итерирующий режим, но вот смущает меня запись в options...
В каком же теперь режиме работает BIND - рекурсивном или итерирующем?

anonymous ()
Ответ на: Re: Проблемы с BIND от anonymous

Re: Проблемы с BIND

А чтобы не сомневаться, добавь recursion yes;

gruy ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.