LINUX.ORG.RU
решено ФорумAdmin

Postfix: TLS is required, but was not offered by host

 , ,


0

1

Использую готовую сборку почтового сервера mailcow dockerized (Version 2023-04b), все настройки по умолчанию. Postfix при отправки писем принудительно требует шифрование от почтовых серверов. Выдает ошибку: TLS is required, but was not offered by host Как я понимаю, требование использования TLS зависит от параметра smtp_tls_security_level. По умолчанию стояло значение «dane», которое должно корректно работать как «may» если у DNS для почтового сервера нет корректной записи TLSA. Перевод в режим «may» так-же ни к чему не приводит. Но если хост включить в таблицу smtp_tls_policy_maps с типом «dane» или «may» то письма улетают. Может ещё какой-то параметр настройки Postfix принудительно требует TLS?



Последнее исправление: illusi0n (всего исправлений: 2)

Ответ на: комментарий от suffix

Спасибо, разобрался с ситуацией. Оказалось что e-mail пользователя был указан в таблице smtp_tls_policy_maps, соответственно для конкретного пользователя было требование использовать TLS.

illusi0n
() автор топика