LINUX.ORG.RU
решено ФорумAdmin

Настройка в Gentoo разрешения имён

 , ,


0

1

Купил маршрутизатор и столкнулся с проблемой.

Страницы стали долго открываться, а у ping по 5 сек. уходит на разрешение имён.

Поискав в инете нашёл, что причина в параллельной отправки запроса по протоколу IPv6. В качестве решения прелагается записать в /etc/resolve.conf

options single-request-reopen

Попробовал, всё заработало, но после перезагрузки или

sudo systemctl restart systemd-resolved

запись стирается.

Как эту запись добавить в /etc/systemd/resolved.conf?

Ни в руководствах ни в интернете ничего не смог найти.

а по протоколу ipv6 он куда отправляет? если ты не прописываешь ipv6 dns то и днс у тебя не работает по ipv6. если прописал 8.8.8.8 как он туда по ipv6 пойдет? вероятно проблема в новом роутере на котором вклбчен ipv6 но не работает. его нужно немного исправить или отключить или настроить. так же можно поправать автонастройку адресов и днс допустим игнорировать ipv6 днс. или вообще отключить автоконфигурирлвание ipv6. то чем управляет gai.conf называется приоритет. даже по ip4 dns можно запросить запись aaa и тут складывается неоднозначная ситуация по какому протоколу постучаться на yandex.ru.

antech ()

и последнее resolvd это кэширующий днс сервер и ты это кэширование только что отключил. отчего твой резолв будет работать только медленее

antech ()

Короче решил проблему другим путём.

options single-request-reopen - добавить не удалось.

Решил так. Там в каталоге /run/systemd/resolve/ есть ещё один файл, называется stub-resolv.conf. Вот я переделал на него символическую ссылку, а в файле /etc/systemd/resolved.conf прописал следующие настройки:

[Resolve]
DNS=192.168.0.1
allbackDNS=
LLMNR=no

После этого проблемы прекратились и интернет летает.

keeper_b ★★★ ()