LINUX.ORG.RU
ФорумAdmin

Не работает соединение с Wireguard.

 , ,


0

1

Стоит сервер wireguard на orange pi с таким конфигом:

[Interface]
Address = 10.8.0.1/24
PostUp = iptables -A FORWARD -i %i -j ACCEPT; iptables -A FORWARD -o %i -j ACCEPT; iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
PostDown = iptables -D FORWARD -i %i -j ACCEPT; iptables -D FORWARD -o %i -j ACCEPT; iptables -t nat -D POSTROUTING -o eth0 -j MASQUERADE
ListenPort = 51820
PrivateKey = xxxxx

[Peer]
PublicKey = xxxxxx
AllowedIPs = 10.8.0.2/32

На системе стоит клиентский конфиг:

[Interface]
PrivateKey = xxxxxxxxx
Address = 10.8.0.2/32
DNS = 10.8.0.1

[Peer]
PublicKey = xxxxxx
AllowedIPs = 0.0.0.0/0, ::/0
Endpoint = xxxxx:51820
PersistentKeepalive = 25

Интернет соединение при включении клиента отсутствует. systemctl status wg-quick@wg0-client.service дает такой вывод:

июн 16 17:35:13 fedora systemd[1]: Starting WireGuard via wg-quick(8) for wg0/client...
июн 16 17:35:13 fedora wg-quick[23738]: wg-quick: `wg0-client' already exists
июн 16 17:35:13 fedora systemd[1]: wg-quick@wg0-client.service: Main process exited, cod>
июн 16 17:35:13 fedora systemd[1]: wg-quick@wg0-client.service: Failed with result 'exit>
июн 16 17:35:13 fedora systemd[1]: Failed to start WireGuard via wg-quick(8) for wg0/cli>

wg-quick: `wg0-client' already exists

Дак тунель походу поднят. Что пишет ″wg show″ на клиенте.

Интернет соединение при включении клиента отсутствует

То есть по вашему, если подняли wg, то сразу появляется инет?

Вы не описали конфигурацию сети, пока что видно, что у вас там есть локальные ip-адреса 10.8.0.0/24, которые не инет ни разу...

mky ★★★★★ ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей