LINUX.ORG.RU
ФорумAdmin

Ошибка корректного присоединения к Домену

 , ,


0

1

Доброго времени суток всем.

Имею в наличии:
Дистрибутив «alt-p9-cinnamon-20201212-x86_64».
Домен «Windows Server 2012R2».

Пытаюсь присоединить машину к домену по статье из вики AltLinux. Все отлично прошло ДО пункта «Настройка ролей и привилегий» из приведенной статьи:
Команда «net ads testjoin» послушно выдает «Join is OK» как и положено.

Но «roleadd 'Администраторы домена' localadmins» и «roleadd 'Пользователи домена' users» выдают ошибку «Error 156: No such group» - хотя такие группы точно существуют на домене. Кроме того, пробовал добавлять специально созданную группу «IT» - результат такой же.

Прошу помощи. Может быть встречался кто-нибудь из пользователей AltLinux (а такие пользователи здесь есть).

Заранее спасибо всем откликнувшимся.

P.S. На форуме AltLinux молчат. По коду ошибки гугление не помогло. Поможите пжл.

★★★★★

У альта есть еще Telegram канал - https://t.me/alt_linux. Основная активность происходит сейчас там. Рекомендую зайти туда - высокий шанс, что так помогут быстрее.

Vovka-Korovka ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Очень интересная история получается. В некоторых моментах ответ корректен, в некоторых - нет.

ivanlex ★★★★★ ()

Проблему решил, вернее нашел причину проблемы.

Автоматические скрипты AltLinux корректно работают только если в dhcp сервере настроен параметр «search domainname». Если этот параметр не настроен, или domainname не совпадает с именем домена, к которому присоединяется ПК, то наблюдаются описанные выше проблемы.

Если настроить сетевой интерфейс статикой, то проблема исчезает. На практике не всегда есть возможность использовать параметр параметр «search». Увы - нюансы бывают разные.

ivanlex ★★★★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.