LINUX.ORG.RU
ФорумAdmin

не пойму как запускать

 


0

1

Существует путь прописанный в

%echo &PATH /usr/local/sbin
заливю туда папки bin, doc, some выполняемый файл находится в bin
%bin-bin
no such file
копирую bin-bin в директорию /usr/local/sbin
%bin-bin
работает
но если в другой папке находится другой ему нужный файл то bin-bin его не найдёт. Если же нужный файл вытащить в директорию /usr/local/sbin то bin-bin его найдёт. Подскажите как выкрутится чтобы всё из папок работало.

заливаю в /usr/local/sbin папки bin, doc, some выполняемый файл находится в bin

Зачем?

Сделай в /opt/ каталог для этого софта, добавь потом в PATH что-то вроде export PATH=/opt/soft/bin/:$PATH (bin-bin должен находиться в /opt/soft/bin/) и далее выполняй bin-bin сколько влезет.

EXL ★★★★★ ()
Последнее исправление: EXL (всего исправлений: 2)

//// заливю туда папки bin, doc, some выполняемый файл находится в bin ////

Ну, если я правильно понял, вы по пути: /usr/local/sbin закидываете еще несколько директорий, в том числе директорию bin. И, получается, что у вас исполняемый файл располагается уже по пути: /usr/local/sbin/bin. Если так, то он и не должен выполняться автоматом без указания пути в оболочке, поскольку необходимо в переменных окружения указывать точный, абсолютный путь до испольняемого файла: PATH /usr/local/sbin/bin

Как то так.

ChAnton ★★ ()
Ответ на: комментарий от EXL

А когда такое случается, что делать

ldd gtk/gtk20-lib.so
	linux-gate.so.1 (0xf7fd0000)
	libgtk-x11-2.0.so.0 => not found
	libgdk-x11-2.0.so.0 => not found
	libatk-1.0.so.0 => not found
	libgio-2.0.so.0 => not found
	libpangoft2-1.0.so.0 => not found
	libpangocairo-1.0.so.0 => not found
	libgdk_pixbuf-2.0.so.0 => not found
	libcairo.so.2 => not found
	libpango-1.0.so.0 => not found
	libfreetype.so.6 => not found
	libfontconfig.so.1 => not found
	libgobject-2.0.so.0 => not found
	libgmodule-2.0.so.0 => not found
	libgthread-2.0.so.0 => not found
	librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf7fa0000)
	libglib-2.0.so.0 => not found
	libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7f80000)
	libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7da4000)
	/lib/ld-linux.so.2 (0xf7fd1000)
saufesma ()
Ответ на: комментарий от EXL

libglib-2.0

У меня такого пакета в репозитории дистрибутива нет.

saufesma ()
Ответ на: комментарий от EXL

Есть такие установленные libglib-object-introspection-perl libglib-perl libglib2.0-0 libglib2.0-bin libglib2.0-data

не установленные libglib2.0-cil libglib2.0-cil-dev libglib2.0-dev libglib2.0-dev-bin

saufesma ()

Для библиотек используется переменная LD_LIBRARY_PATH

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от saufesma

Есть – прочитать инструкцию к пакетному менеджеру твоего дистрибутива (который ты так и не сказал) по поводу установки 32-битных пакетов.

EXL ★★★★★ ()
Ответ на: комментарий от saufesma

search не найдёт, там надо указывать архитектуру вроде в опциях команды

$ uname -a
Linux XPC 5.9.9 #1 SMP Fri Nov 20 20:40:10 MSK 2020 x86_64 x86_64 x86_64 GNU/Linux
$ ll /lib/i386-linux-gnu/libpthread.so.0
lrwxrwxrwx 1 root root 18 авг 17 23:02 /lib/i386-linux-gnu/libpthread.so.0 -> libpthread-2.31.so*

# dpkg --add-architecture i386 <-- должно помочь

superuser ★★★★ ()
Ответ на: комментарий от superuser

И затем ставится 32-битный GTK+2 из реп со всеми его зависимостями для запуска его некрософтины.

EXL ★★★★★ ()
Ответ на: комментарий от EXL

После того как

# dpkg --add-architecture i386 <-- должно помочь

И затем ставится 32-битный GTK+2 из реп со всеми его >зависимостями для запуска его некрософтины.

Я правильно понял?

saufesma ()
Ответ на: комментарий от EXL

вот ввод/вывод

$ sudo dpkg –add-architecture i386 [sudo] password for :
$

И затем ставится 32-битный GTK+2 из реп со всеми его >зависимостями для запуска его некрософтины. А где репы брать и какие и запутался

saufesma ()
Ответ на: комментарий от EXL

Synaptic Package Manager Search All ничего не даёт. А других стандартных мест я не знаю.

libgtk-x11-2.0.so.0 => not found
	libgdk-x11-2.0.so.0 => not found
	libatk-1.0.so.0 => not found
	libgio-2.0.so.0 => not found
	libpangoft2-1.0.so.0 => not found
	libpangocairo-1.0.so.0 => not found
	libgdk_pixbuf-2.0.so.0 => not found
	libcairo.so.2 => not found
	libpango-1.0.so.0 => not found
	libfreetype.so.6 => not found
	libfontconfig.so.1 => not found
	libgobject-2.0.so.0 => not found
	libgmodule-2.0.so.0 => not found
	libgthread-2.0.so.0 => not found
saufesma ()
Ответ на: комментарий от saufesma

Вот на Xubuntu 20.04 есть

$ apt-file search -a i386 libgdk-x11-2.0.so.0
libgtk2.0-0: /usr/lib/i386-linux-gnu/libgdk-x11-2.0.so.0
libgtk2.0-0: /usr/lib/i386-linux-gnu/libgdk-x11-2.0.so.0.2400.32
но кажется ты нас троллишь

superuser ★★★★ ()
Последнее исправление: superuser (всего исправлений: 1)
Ответ на: комментарий от superuser

но кажется ты нас троллишь

Во первых я не знаю что это такое во вторых не системный администратор, просто хотел посмотреть Allegro CL, а бесплатная версия 32 бита.

Моё соединение от 2000 B/s до 100 kB/s, поэтому мне сложно быть на связи.

saufesma ()
Ответ на: комментарий от EXL

[code] $ sudo apt-get install gtk2.0:i386 [sudo] password for wool:
Reading package lists… Done Building dependency tree
Reading state information… Done Note, selecting ‘librccgtk2-0:i386’ for regex ‘gtk2.0’ Note, selecting ‘libgtk2.0-bin:i386’ for regex ‘gtk2.0’ Note, selecting ‘libgtk2.0-cil:i386’ for regex ‘gtk2.0’ Note, selecting ‘libgtk2.0-dev:i386’ for regex ‘gtk2.0’ Note, selecting ‘libgtk2.0-doc:i386’ for regex ‘gtk2.0’ Note, selecting ‘gtk2.0-examples:i386’ for regex ‘gtk2.0’ Note, selecting ‘libgtk2.0-0:i386’ for regex ‘gtk2.0’ Note, selecting ‘monodoc-gtk2.0-manual:i386’ for regex ‘gtk2.0’ Note, selecting ‘uim-gtk2.0-immodule:i386’ for regex ‘gtk2.0’ Note, selecting ‘libgtk2.0-common:i386’ for regex ‘gtk2.0’ Note, selecting ‘libgtk2.0-cil-dev:i386’ for regex ‘gtk2.0’ Note, selecting ‘uim-gtk2.0:i386’ for regex ‘gtk2.0’ Note, selecting ‘gtk2.0-binver-2.10.0:i386’ for regex ‘gtk2.0’ Note, selecting ‘libgwengui-gtk2-0:i386’ for regex ‘gtk2.0’ Note, selecting ‘libgtk2.0-common’ instead of ‘libgtk2.0-common:i386’ Note, selecting ‘libgtk2.0-0:i386’ instead of ‘gtk2.0-binver-2.10.0:i386’ Note, selecting ‘libgtk2.0-doc’ instead of ‘libgtk2.0-doc:i386’ libgtk2.0-common is already the newest version (2.24.32-1ubuntu1). Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: libgtk2.0-cil:i386 : Depends: cli-common:i386 (>= 0.5.6) but it is not installable Depends: libglib2.0-cil:i386 (= 2.12.40-2) but it is not going to be installed Depends: libmono-cairo4.0-cil:i386 (>= 4.0.4.1) but it is not installable Depends: libmono-corlib4.5-cil:i386 (>= 4.6.1.3) but it is not installable Depends: libmono-system-drawing4.0-cil:i386 (>= 4.6.1.3) but it is not installable libgtk2.0-cil-dev:i386 : Depends: libglib2.0-cil-dev:i386 (= 2.12.40-2) but it is not going to be installed E: Unable to correct problems, you have held broken packages. [/code]

saufesma ()
Ответ на: комментарий от EXL

То же самое, наверное надо закруглять это дело

ldd gtk/gtk20-lib.so
	linux-gate.so.1 (0xf7f88000)
	libgtk-x11-2.0.so.0 => not found
	libgdk-x11-2.0.so.0 => not found
	libatk-1.0.so.0 => not found
	libgio-2.0.so.0 => not found
	libpangoft2-1.0.so.0 => not found
	libpangocairo-1.0.so.0 => not found
	libgdk_pixbuf-2.0.so.0 => not found
	libcairo.so.2 => not found
	libpango-1.0.so.0 => not found
	libfreetype.so.6 => not found
	libfontconfig.so.1 => not found
	libgobject-2.0.so.0 => not found
	libgmodule-2.0.so.0 => not found
	libgthread-2.0.so.0 => not found
	librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf7f58000)
	libglib-2.0.so.0 => not found
	libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7f38000)
	libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7d5c000)
	/lib/ld-linux.so.2 (0xf7f89000)

saufesma ()
Ответ на: комментарий от saufesma

Это коряво собранные убунтовские пакеты наверно.
Это когда в deb-пакетах например

  • libglib2.0-cil-dev:i386
  • libglib2.0-cil-dev:amd64

есть файлы, расположенные по одинаковому пути.
В таких случаях я находил эти deb-пакеты (вручную увы, т.к. из выхлопа не очень понятно в каких именно deb-пакетах эти файлы пересекаются), перепаковывал и устанавливал.

И вообще не понятно почему в дереве зависимостей для gtk2.0 прописаны ***-dev пакеты. Хотя чё не понятно, всё понятно - коряво собранные пакеты.

superuser ★★★★ ()
Последнее исправление: superuser (всего исправлений: 3)
Ответ на: комментарий от saufesma

наверное надо закруглять это дело

Лучше на нормальном дистрибутиве попробовать твою программу запустить, чем на этом DEB-позорище.

Ну или возьми просто 32-битную сборку Mint накати куда-нибудь в виртуалку/чрут/контейнер и без проблем запусти там.

EXL ★★★★★ ()
Последнее исправление: EXL (всего исправлений: 1)
Ответ на: комментарий от EXL

Ну или возьми просто 32-битную сборку Mint накати куда-нибудь в >виртуалку/чрут/контейнер и без проблем запусти там.

Извини язык чешется. Есть в просторах интернета OpenGENERA 8.1 с LVM у меня она запускается но не могу дать прав доступа к файловой системе, а без этого она не особо интересна. Или у меня такая сборка, что доступа нет.

saufesma ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.