LINUX.ORG.RU
ФорумAdmin

Редирект с hhtp на https в apache2 на Gentoo

 ,


0

2

Здравия! Сделал по инструкциям и в .htaccess и в конфе апача. Как не старался менять данные из разных источников в конфиге полноценно не получается. Сейчас такое

 

Bad Request

Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.

Мой .htaccess сейчас закомментирован редирект, но всё же выложу, что пробовал там

$ cat /var/www/localhost/htdocs/.htaccess 
#RewriteEngine On
#RewriteCond %{HTTPS} !=on
#RewriteRule ^/?(.*) https://%{stepsmig.ru}/$1 [R,L]
Options -Indexes

Конф апача:

<VirtualHost *:80>
  ServerName stepsmig.ru
  RewriteEngine on
  RewriteCond %{HTTP_HOST}  ^stepsmig.ru$ [NC]
  RewriteRule (.*) https://stepsmig.ru$1 [R=permanent,L]
</VirtualHost>

И тут я в замешательстве, дальше не знаю что делать.

★★★

Сначла в /etc/conf.d/apache2 ты включаешь модуль ssl:

APACHE2_OPTS="... -D SSL -D SSL_DEFAULT_VHOST ..."

И перезапускаешь apache2.

Apache собираешь с включенным флагом ssl.

Потом в файле конфига на 80 порту твоего домена прописываешь

<VirtualHost *:80>
    ServerName domain.ru
    Redirect Permanent / https://domain.ru/
    DocumentRoot /var/www/html/domain.ru    
        <Directory /var/www/html/domain.ru>
        AllowOverride All
    </Directory>
</VirtualHost> 

А в файле конфигра на 443 порту твоего домена прописываешь сертификаты

<VirtualHost *:443>
    ServerName domain.ru
    DocumentRoot /var/www/html/domain.ru 
        <Directory /var/www/html/domain.ru>
        AllowOverride All
    </Directory>
               SSLCertificateFile /etc/letsencrypt/live/domain.ru/cert.pem
               SSLCertificateKeyFile /etc/letsencrypt/live/domain.ru/privkey.pem
               SSLCertificateChainFile /etc/letsencrypt/live/domain.ru/chain.pem
</VirtualHost> 

anonymous ()
Ответ на: комментарий от anonymous

Всё сделано, конфиг ссл-а, в конфиге на 80 порту указал точно так, как нужно, апач собран с флагом ssl, сертификаты прописаны и работают как надо. Вот редирект не работает, всё то же:

«Bad Request

Your browser sent a request that this server could not understand. Reason: You're speaking plain HTTP to an SSL-enabled server port. Instead use the HTTPS scheme to access this URL, please.»

burato ★★★ ()
Ответ на: комментарий от burato

Апач есть слишком много ресурсов.

Если у тебя будет заходить одновременно 5-10 человек, то нормально.

А если несколько сотен - то nginx, php-fpm и как минимум 16 Гб ОЗУ.

anonymous ()