LINUX.ORG.RU
ФорумAdmin

OpenWrt+Wireguard

 


0

1

Всех приветствую.

Пытаюсь настроит wg, Все вроде настроил, но ip адрес не меняется на адрес сервера VPS, а когда ставишь: Маршрутизировать разрешенные IP-адреса, интернет вообще отваливается. Помогите пожалуйста

на стороне сервера:

interface: wg0
  public key: ***
  private key: (hidden)
  listening port: 51820 


peer: 
  preshared key: (hidden)
  endpoint: ****
  allowed ips: 10.8.0.3/32, fd42:42:42::3/128
  latest handshake: 1 minute, 40 seconds ago
  transfer: 201.96 KiB received, 1.73 KiB sent

на стороне клиента:

interface: wg0
  public key: ****
  private key: (hidden)
  listening port: 45912

peer: ****
  preshared key: (hidden)
  endpoint: ***
  allowed ips: 0.0.0.0/0, ::/0
  latest handshake: 1 minute, 57 seconds ago
  transfer: 460 B received, 1.77 KiB sent
  persistent keepalive: every 25 seconds

Вот конфиги:

config interface 'wg0'
	option proto 'wireguard'
	option private_key '*****'
	option mtu '1280'
	list addresses '10.8.0.3/24'
	list addresses 'fd42:42:42::3/64'

config wireguard_wg0
	option persistent_keepalive '25'
	option public_key '*****'
	option description 'wg0'
	option endpoint_port '51820'
	option endpoint_host '****'
	option preshared_key '****'
	option route_allowed_ips '1'
	list allowed_ips '0.0.0.0/0'
config zone
	option name 'wg'
	option network 'wg0'
	option input 'REJECT'
	option forward 'REJECT'
	option masq '1'
	option output 'ACCEPT'

config forwarding
	option dest 'wan'
	option src 'wg'