LINUX.ORG.RU
ФорумAdmin

Проблемы при переходе с samba 2.0.7->2.2.3


0

0

У меня по default'у стояла samba-2.0.7 в RPM А сейчас вышла новая samba-2.2.3 в сырцах . Сначала я остановил сервисы smbd & nmbd - потом через kpackage удалил samba ... Сначала сделал : ./configure --with-smbwrapper --with-msdfs --with-vfs make make install Но вообщем не запустилась (кстати скрипт /etc/init.d/smb пришлось восстанавливать из SMB-HOWTO т.к. он убился когда я унинсталировал страую версию самбы) - потом я понял что файлы nmbd & smbd находятся не в /usr/bin/ а в /usr/local/samba/bin/ Тогда я сделал так: make unistall ./configure --exec-prefix='/usr' --with-smbwrapper --with-msdfs --with-vfs make make install но все равно не запустилось - Помогите решить проблему ... Можно пересылать в мыло dexim@cydem.zp.ua

anonymous

Re: Проблемы при переходе с samba 2.0.7->2.2.3

Прежде чем инсталлировать make install вполне можно сказать

make -n install > aaa

Это создает пакетник инсталляции, из которого видно - куда оно собирается ставиться. Но это еще не все. Там еще ей нужно указать, чтобы она логи клала куда надо, чтобы smb.conf искала там, где надо, а не хрен знает где. В том числе --with-sysconfdir=/etc --with-lockdir=/var/lock и т. д. У меня была версия 2.2.2

Dimai ()
Ответ на: Re: Проблемы при переходе с samba 2.0.7->2.2.3 от novocel

Re: Re: Проблемы при переходе с samba 2.0.7->2.2.3

Зайди в /samba-2.2.3/packaging/RedHat ну и сделай sh makerpms.sh он сам всё сделает как надо и положит готовый RPM в /usr/src/redhat/RPMS/i386 Если у тебя не RH в packaging есть много всяких скриптов.

anonymous ()

Re: Проблемы при переходе с samba 2.0.7->2.2.3

novocel - Thanx ! Все заработало ... Создание rpm наиболее легий путь . Разработчики Самбы уже сами прописали все нужные пути для RH ... ;)

Всем спасибо .

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.