LINUX.ORG.RU
ФорумAdmin

postfix отправляет только на локальные адреса

 ,


0

1

Отправляю письмо на адрес который настроен postfix - все ходит. Пробую отправить на gmail - ошибка

Dec 19 13:12:42 user postfix/smtpd[30690]: NOQUEUE: reject: RCPT from [skipped]: 454 4.7.1 <my_account@gmail.com>: Relay access denied; from=<***@my.domain> to=<my_account@gmail.com> proto=ESMTP helo=<[192.168.99.83]>

Адреса указаны правильно.

Config:

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# See http://www.postfix.org/COMPATIBILITY_README.html -- default to 2 on
# fresh installs.
compatibility_level = 2

# TLS parameters
#smtpd_tls_cert_file = /etc/letsencrypt/live/zzz/fullchain.pem
#smtpd_tls_key_file = /etc/letsencrypt/live/zzz/privkey.pem

smtpd_use_tls=no
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
myhostname = my.domain
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = my.domain, localhost.localdomain, localhost
relayhost = 

mynetworks = 127.0.0.0/8 my.domain [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all

Ответ на: комментарий от Tuxford

Какая именно проблема?

Данный параметр ограничивает отправку почты неавторизованными отправителями только на адреса в Ваших доменах. Отправка на внешние адреса возможна только после авторизации (и это правильно, иначе бы получился open relay). Так что разбирайтесь с sasl-авторизацией при отправке писем.

Serge10 ★★★★★ ()
Ответ на: комментарий от Serge10

Если я правильно понял, то у меня настроена sasl авторицазиция на отправку. Мне следует настроить saslauthd и postfix’у указатть что авторизировать через saslauthd

Я иду в правильном направлении?

Tuxford ()
Ответ на: комментарий от Tuxford

то у меня настроена sasl авторицазиция на отправку.

Логин и пароль при отправке запрашиваются?

Я иду в правильном направлении?

Да, разбираться надо с авторизацией отправки.

Вот здесь есть не только инструкции по настройке, но и описание того, как можно протестировать систему с помощью обычного telnet.

Serge10 ★★★★★ ()
Ответ на: комментарий от Serge10

Логин и пароль при отправке запрашиваются?

Нет

telnet my.host 25
Trying *.*.*.*...
Connected to my.host.
Escape character is '^'.
220 my.host ESMTP Postfix (Ubuntu)
ehlo my.host
250-my.host
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-DSN
250 SMTPUTF8
auth plain mylogin mypass
503 5.5.1 Error: authentication not enabled

Вот это удивляет.

Вот здесь есть не только инструкции

Спасибо, буду осиливать.

Rainbow ()