LINUX.ORG.RU
ФорумAdmin

не работает WOL в Centos 7

 ,


0

1

Я уже поднимал тему, но тогда был другой случай, моя встроенная сетевушка не поддерживала WOL в принципе. Ну что делать воткнул сетевуху которая поддерживает WOL настроил и все стало хорошо опять до какого то определенного момента, видать обновил CENTOS и ФСЁ…. вот и думай обновляться или нет если у тебя все работает…

проверяю wol она умеет:

ethtool enp2s0 | grep Wake-on
Supports Wake-on: pumbg
Wake-on: d

Wol отключен, включаю

ethtool -s enp2s0 wol g

перепроверяю

 ethtool enp2s0 | grep Wake-on
        Supports Wake-on: pumbg
        Wake-on: g

Все замечательно казалось бы. прописываю всячески в настройках сетевушки

ETHTOOL_OPTS=»-s enp2s0 wol g»
ETHTOOL_OPTS=»-s ${DEVICE} wol g»
ETHTOOL_OPTIONS=»wol g»

При перезагрузке опять все как было. В сети нашел коллегу дебианщика, у него та же беда, цитирую ответ

Такая же ерунда с сервером на debian, где proxmox стоит. 
Раньше просыпался по сети, потом в какой-то момент перестал. 
Почему так — не могу понять. Ничего не помогает.

Коллеги может у вас есть какие мысли, ну нужон мне этот WOL, хотя понимаю, что вы не волшебники, но как в рекламе «а что, а вдруг?»

Что мешает перед выключением системы выполнить «ip li set dev enp2s0 up && ethtool -s enp2s0 wol g» и убедиться, что halt не выключает сетевые интерфейсы?

Еще настройки bios сильно влият на работоспособность WoL.

Многие десктопные матери принципиально не умеют включать WoL после включения питания, но и это можно обойти.

vel ★★★★★ ()
Последнее исправление: vel (всего исправлений: 1)

А у Вас линк горит после прдеполагаемого выключения или сетевая тоже тухнет?
Со стороны комутатора/маршрутизатора можете посмотреть?

i3wm ()
Ответ на: комментарий от vel

Что мешает перед выключением системы выполнить «ip li set dev enp2s0 up && ethtool -s enp2s0 wol g» и убедиться, что halt не выключает сетевые интерфейсы?

попробую, но а разве не тоже самое делаю? И не halt а даже reboot и настроек как не бывало

Еще настройки bios сильно влият на работоспособность WoL.

Про настройки не стал повторяться, у меня два винта на компе, на одном винда, на другом centos 7 так вот с виндой проблем нет. Те в биосе все включено как надо и еще раз повторюсь какое то время и на Centos тоже работало.

alex_sim ★★ ()
Ответ на: комментарий от i3wm

А у Вас линк горит после прдеполагаемого выключения или сетевая тоже тухнет? Со стороны комутатора/маршрутизатора можете посмотреть?

А не гинеколог, но посмотреть могу :))) ( шутка) мне кажется нечего там смотреть, если не просыпается значит и линк не горит если бы горел просыпалась бы тачка.

alex_sim ★★ ()
Ответ на: комментарий от i3wm

у меня:

lspci|grep Ethernet
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

тока что то не понимаю, что делать, башка уже не соображает наверно завтра буду изучать вражий

alex_sim ★★ ()
Ответ на: комментарий от alex_sim

Пофиг что при старте оно 'd'.

Это действие должно быть выполнено непосредственно перед командой halt где-то в скриптах выполняемых при poweroff.

Если все сделано правильно, то линк должен остаться во включеном состоянии.

vel ★★★★★ ()
Ответ на: комментарий от vel

Пофиг что при старте оно ‘d’.

те когда я устанавливаю ‘g’ перед ребутом, какая то сволочь после загрузки сбрасывает в ‘d’ но в принципе должно будиться…. сейчас открою серверную проверю.

Если все сделано правильно, то линк должен остаться во включеном состоянии

Это понятно

alex_sim ★★ ()
Ответ на: комментарий от vel

Пофиг что при старте оно ‘d’.

установил G сделал poweroff, бесполезно линк не горит и не будится соответсвенно.

Ядер у меня уже штук 5 можно вычислить на каком сломалось конечно… но как то не спортивно это.

alex_sim ★★ ()
Последнее исправление: alex_sim (всего исправлений: 1)