LINUX.ORG.RU

OpenSUSE-не устанавливается python пакет esmre

 ,


0

1
% sudo pip2.7 install esmre    
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Collecting esmre
  Using cached https://files.pythonhosted.org/packages/50/b0/17401277ddaa334622c047f9c9a083956e67f8b08c7b8b43ade0b588f349/esmre-0.3.1.tar.gz
Requirement already satisfied: setuptools in /usr/lib/python2.7/site-packages (from esmre) (40.0.0)
Installing collected packages: esmre
  Running setup.py install for esmre ... error
    ERROR: Complete output from command /usr/bin/python -u -c 'import setuptools, tokenize;__file__='"'"'/tmp/pip-install-GQ3531/esmre/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-q35OMc/install-record.txt --single-version-externally-managed --compile:
    ERROR: running install
    running build
    running build_py
    creating build
    creating build/lib.linux-x86_64-2.7
    copying src/esmre.py -> build/lib.linux-x86_64-2.7
    running build_ext
    building 'esm' extension
    creating build/temp.linux-x86_64-2.7
    creating build/temp.linux-x86_64-2.7/src
    gcc -pthread -fno-strict-aliasing -fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -g -DNDEBUG -fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -g -DOPENSSL_LOAD_CONF -fwrapv -fPIC -I/usr/include/python2.7 -c src/esm.c -o build/temp.linux-x86_64-2.7/src/esm.o
    src/esm.c:19:20: fatal error: Python.h: Нет такого файла или каталога
     #include <Python.h>
                        ^
    compilation terminated.
    error: command 'gcc' failed with exit status 1
    ----------------------------------------
ERROR: Command "/usr/bin/python -u -c 'import setuptools, tokenize;__file__='"'"'/tmp/pip-install-GQ3531/esmre/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-q35OMc/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-install-GQ3531/esmre/

Ответ на: комментарий от Thetan

Ты хоть и злой, Thetan, но соображаешь:


% sudo pip2.7 install esmre
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Collecting esmre
  Using cached https://files.pythonhosted.org/packages/50/b0/17401277ddaa334622c047f9c9a083956e67f8b08c7b8b43ade0b588f349/esmre-0.3.1.tar.gz
Requirement already satisfied: setuptools in /usr/lib/python2.7/site-packages (from esmre) (40.0.0)
Installing collected packages: esmre
  Running setup.py install for esmre ... done
Successfully installed esmre-0.3.1

gigantischer ()