LINUX.ORG.RU

Для запуска Linux нужно ядро, Initramfs и указанный корневой раздел в параметрах ядра.

anonymous ()
Ответ на: комментарий от anonymous

Сделал так

# SAFE MODE
image=/boot/vmlinuz-4.9.0-6-amd64
label= "failsafe"
initrd = /boot/initrd.img-4.9.0-6-amd64
root = "UUID=cc1e10fd-a3ee-4739-9ee8-5b8e05803053"
append="failsafe"
read-only

Но ОС загружается в обычном режиме

UriyZenkov ()
Ответ на: комментарий от UriyZenkov

А твой initrd и система инициализации умеет обрабатывать параметр failsafe?

Посмотри что в /proc/cmdline в загруженной системе с этого пункта меню.

anonymous ()
Ответ на: комментарий от UriyZenkov

ну всё, как ты видишь твой параметр добавился.

В общем, failsafe параметр обрабатывает система инициализации Ubuntu, может ещё Debian.

А у тебя какой дистрибутив там стоит?

anonymous ()
Ответ на: комментарий от UriyZenkov

Читай тогда документацию какой параметр нужно добавить в параметры ядра, что бы система запускалась в recovery режиме.

А так с lilo ты всё делаешь правильно.

А зачем тебе грузиться в режиме восстановления или в каком режиме нужно грузиться, что случилось-то?

anonymous ()
Ответ на: комментарий от UriyZenkov

Поставь значит систему с Grub куда-нибудь и посмотри какие параметры добавлены в пункт запука в режиме восстановления, ну либо читай документаци по Devuan.

А почему grub не устанавливается, в чём проблема?

anonymous ()
Ответ на: комментарий от anonymous

Получилось

Нужно было вместо append=«failsafe» ввести append=«single»

UriyZenkov ()

Получилось:

# SAFE MODE

image=/boot/vmlinuz-4.9.0-6-amd64

label= «failsafe»

initrd = /boot/initrd.img-4.9.0-6-amd64

root = «UUID=cc1e10fd-a3ee-4739-9ee8-5b8e05803053»

append=«single»

read-only

UriyZenkov ()
Ответ на: комментарий от anonymous

Ставил Дебианы, начиная с 7,8,9 на два совершенно разных ноутбука. Везде при установке Дебиана ошибка установки Grub, приходилось возвращаться по пунктам установщика вниз и выбирать lilo. Grub как-то нестабильно устанавливается: нужно раз 10-15 ввести grub-install /dev/sda чтоб он нормально установился. Вводишь первый раз grub-install /dev/sda, при загрузке компа появляются одни артефакты вместо загрузчика, вводишь второй раз grub-install /dev/sda - другие артефакты, третий - третье. И так пока grub не установиться нормально. Проверял установку груба командой kvm /dev/sda

Да и lilo мне, как простому пользователю намного проще.

UriyZenkov ()
Ответ на: Получилось: от UriyZenkov

Re: Получилось:

Ну так ты бы и написал, что хочешь загрузиться в однопользовательском режиме.

А то пишешь «failsafe».

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.