LINUX.ORG.RU

Нестабильный пинг OpenVPN

 , , , ,


1

1

Доброго времени суток, имеется дедик на Ubunntu 16.04, на нем поднят OpenVPN сервер, на клиенте Win 7. Проблема в скачущем пинге и медленной загрузке сайтов. Даже трассировка еле-еле ползет.

Пинг до любого ресурса выглядит примерно так (в данном случае google.com):

Ответ от 172.217.16.206: число байт=32 время=55мс TTL=55 
Ответ от 172.217.16.206: число байт=32 время=55мс TTL=55 
Ответ от 172.217.16.206: число байт=32 время=55мс TTL=55 
Ответ от 172.217.16.206: число байт=32 время=1702мс TTL=55 
Ответ от 172.217.16.206: число байт=32 время=1249мс TTL=55 
Ответ от 172.217.16.206: число байт=32 время=55мс TTL=55 
Ответ от 172.217.16.206: число байт=32 время=55мс TTL=55

Пинги внутри впн между клиентом и сервером стабильные, пинг до ip сервера с отключенным впн стабилен.

Винда чистая, до этого на клиенте стояла десятка, таких проблем не наблюдалось. Также попробовал с другого компа и провайдера, все нормально. Подключаюсь через OpenVPN GUI.

Конфиг клиента

client 
dev tun 
proto udp 
sndbuf 0 
rcvbuf 0 
remote nnn 
resolv-retry infinite 
nobind 
persist-key 
persist-tun 
remote-cert-tls server 
auth SHA512 
cipher AES-256-CBC 
comp-lzo 
setenv opt block-outside-dns 
key-direction 1 
verb 5

Конфиг сервера

port 1196 
proto udp 
dev tun 
sndbuf 0 
rcvbuf 0 
ca ca.crt 
cert server.crt 
key server.key 
dh dh.pem 
auth SHA512 
tls-auth ta.key 0 
topology subnet 
server 10.8.0.0 255.255.255.0 
ifconfig-pool-persist ipp.txt 
push "redirect-gateway def1 bypass-dhcp" 
push "dhcp-option DNS 1.1.1.1" 
push "dhcp-option DNS 1.0.0.1" 
keepalive 10 120 
cipher AES-256-CBC 
comp-lzo 
user nobody 
group nogroup 
persist-key 
persist-tun 
#status openvpn-status.log 
log /var/log/openvpn.log 
verb 3 
mute 20 
crl-verify crl.pem

Все что я напишу конечно полная фигня! Но параметры попробовать для конфига клиента:

mtu-test // подождать несколько минут после запуска
tun-mtu // сразу прописать значение поменьше
mssfix // прописать значение поменьше, не имеет отношения к пингу, но к tcp да

А серьезно я бы посмотрел tcpdump на сервере, одновременно на интерфейсах как tun так и исходящем, что бы понять где проблема.

anc ★★★★★ ()
Ответ на: комментарий от anc

Сейчас попробовал еще раз с другого клиента, win 10, с первоначальным конфигом, который в шапке, никаких проблем. А то я уже подумал, может провайдер DPI тестирует :) Но нет, видимо, пришло время переустанавливать Шindows

SP1kery ()