LINUX.ORG.RU
ФорумAdmin

dsl, pppoe: «Remote message: Wrong Realm»


0

0

Здравствуйте!
Подключаюсь с использованием rp-pppoe (ну, там adsl-setup и т.д.)
Вот что в логах (запускаюсь через adsl-start):

Using interface ppp0
Connect: ppp0 <--> /dev/pts/1
sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xfc0534af>]
sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xfc0534af>]
rcvd [LCP ConfAck id=0x1 <mru 1492> <magic 0xfc0534af>]
rcvd [LCP ConfAck id=0x1 <mru 1492> <magic 0xfc0534af>]
sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xfc0534af>]
rcvd [LCP ConfAck id=0x1 <mru 1492> <magic 0xfc0534af>]
rcvd [LCP ConfReq id=0x2 <mru 1400> <auth pap> <magic 0xed7f9e43>]
sent [LCP ConfAck id=0x2 <mru 1400> <auth pap> <magic 0xed7f9e43>]
sent [LCP EchoReq id=0x0 magic=0xfc0534af]
sent [PAP AuthReq id=0x1 user="xxx55myb76xxx" password=<hidden>]
rcvd [LCP EchoRep id=0x0 magic=0xed7f9e43]
rcvd [PAP AuthNak id=0x1 "Wrong Realm"]
Remote message: Wrong Realm
PAP authentication failed
sent [LCP TermReq id=0x2 "Failed to authenticate ourselves to peer"]
rcvd [LCP TermReq id=0x3]
sent [LCP TermAck id=0x3]
rcvd [LCP TermAck id=0x2]
Connection terminated.

помогите расшифровать сабжевое сообщение об ошибке (повторю его)
rcvd [PAP AuthNak id=0x1 "Wrong Realm"]
Remote message: Wrong Realm

Погуглил, но о таких ошибках никто не спрашивал :(
Мне кажется, что я передаю аутентификационные данные в каком-то формате, который провайдер не принимает, какие параметры покрутить?

Дополнительная инфа:
tcpdump на той сетевухе, которая к модему подключена видит пакеты, которые за двумя модемами (ну там, netbios, короче сетку вижу, причем айпишники похожие на тот, который мне выделен (который будет у меня на ppp0, когда заработает :)))
Ну и традиционная тема:
"Под виндой все работает (с)"

Спасибо. Дмитрий

anonymous

Re: dsl, pppoe: "Remote message: Wrong Realm"

Добрый день, это опять я :)
кратко отвечаю на свой вопрос:
Я предполагал, что pppoe сервер запрашивает даные об авторизации в каком-то определенном формате, так и оказалось.
Гугленье дало очень мало, как я и писал - ИМЕННО ТАКОГО сообщения об ошибке я вообще не встретил ни разу.
Пришлось изучать маны, rfc - сравнив даты моих постов сюда, видно, что некоторое время я на это потратил :)
Изучал я вcякие доки, имеющие отношение к теме, в т.ч. и для windows.
В одном из таких доков был скриншот подключения к прову и такая запись в поле ввода логина:
Ваш логин@pppoe
ну, я бы не придал этому значения, но на N-ные сутки пробуешь все варианты....поправил конфиги (так и добавил - @pppoe) и увидел долгожданую надпись "connected"
Всем спасибо.
Дмитрий

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.