LINUX.ORG.RU

Проблема с заходом на сервер по ключу

 , ,


0

2

В общем, я похоже что-то сломал, и это что-то мешает мне зайти по ключу на сервер.

Кастую вот эти парочки команд:

ssh-keygen ssh-copy-id user@host

Но в итоге при попытке зайти на сервер он все равно спрашивает пароль (всегда).

Выхлоп логов прилагаю. Всем спасибо за помощь, а то это просто ппц какой-то. :(

OpenSSH_7.2p2 Ubuntu-4ubuntu2.1, OpenSSL 1.0.2g  1 Mar 2016
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for 192.168.202.212
debug1: Connecting to 192.168.202.212 [192.168.202.212] port 22.
debug1: Connection established.
debug1: identity file /home/user/.ssh/id_rsa type 1
debug1: key_load_public: No such file or directory
debug1: identity file /home/user/.ssh/id_rsa-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.2p2 Ubuntu-4ubuntu2.1
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.2p2 Ubuntu-4ubuntu2.1
debug1: match: OpenSSH_7.2p2 Ubuntu-4ubuntu2.1 pat OpenSSH* compat 0x04000000
debug1: Authenticating to 192.168.202.212:22 as 'user'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256@libssh.org
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:mh2YToF0zQlWXEYYZd5uemlVPrDs72qZ0KhMuhY0eKQ
debug1: Host '192.168.202.212' is known and matches the ECDSA host key.
debug1: Found key in /home/user/.ssh/known_hosts:1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<rsa-sha2-256,rsa-sha2-512>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/user/.ssh/id_rsa
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: password

А настройка сервера разрешает ходить только по ключу?

conformist ★★★ ()

Тут нихрена не видно, нужны логи sshd с сервера.

anonymous ()
Ответ на: комментарий от conformist

А настройка сервера разрешает ходить только по ключу?

Authentications that can continue: publickey,password

anonymous ()

права но хомдир, .ssh, файлы в .ssh

на сервере

futurama ★★★ ()
Последнее исправление: futurama (всего исправлений: 1)

Думаю, стоит привести конфиг sshd.

Hanuken ()
Ответ на: комментарий от conformist

Не, там есть возможность подключаться по паролю. Но если я пароль уберу, то боюсь могу не подключиться к виртуалке, а прямого физического доступа у меня к ней нет.

ivan_dav ()
Ответ на: комментарий от Hanuken

Прошу прощения, вчера не догадался про это :(

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
HostKey /etc/ssh/ssh_host_ed25519_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 1024

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin prohibit-password
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile	%h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM ye
ivan_dav ()
Ответ на: комментарий от anonymous

Права везде есть, насколько я вижу. Сейчас ради теста поставил папке .ssh 777, но это особо ничего не дало.

ivan_dav ()

Всем спасибо. Разобрался самостоятельно. Проблема была с правами на сервере, куда я коннектился. Сделал chown на домашнюю директорию пользователя и дал права 700 на .ssh (из-за избыточных прав может тоже ругаться).

ivan_dav ()
Ответ на: комментарий от futurama

Последние два слова «на сервере» надо было жирнейщим образом выделить, чтобы так не тупил. А то после того как на сервере в auth.log начал отлавливать Authentication refused: bad ownership or modes for directory сразу познал дзен, а все в логах именно клиента искал какой-то косяк :)

ivan_dav ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.