LINUX.ORG.RU
ФорумAdmin

Обновил php, прошу помощи не убить боевой сервер

 ,


0

1

Вчера один скрипт новой версии написал что ему надо php 5.4. Сделал следущее

yum install centos-release-SCL
yum install php54 php54-php php54-php-gd php54-php-mbstring
yum install php54-php-mysqlnd
mv /etc/httpd/conf.d/php.conf /etc/httpd/conf.d/php53.off
service httpd restart

Теперь получается какая то каша, хочу удалить php 5.4.

# php -v
PHP 5.3.3 (cli) (built: Aug 11 2016 20:33:53)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
[root@teapage ~]# rpm -qa | grep php
php-mysql-5.3.3-48.el6_8.x86_64
php-process-5.3.3-48.el6_8.x86_64
php54-runtime-2.0-1.el6.x86_64
php54-php-xml-5.4.40-4.el6.x86_64
php54-2.0-1.el6.x86_64
php54-php-mysqlnd-5.4.40-4.el6.x86_64
php-mcrypt-5.3.3-5.el6.x86_64
php54-php-common-5.4.40-4.el6.x86_64
php54-php-process-5.4.40-4.el6.x86_64
php54-php-pear-1.9.4-10.sc1.el6.noarch
php54-php-gd-5.4.40-4.el6.x86_64
php54-php-5.4.40-4.el6.x86_64
php54-php-pdo-5.4.40-4.el6.x86_64
php-domxml-php4-php5-1.21.2-1.el6.noarch
php-common-5.3.3-48.el6_8.x86_64
php-cli-5.3.3-48.el6_8.x86_64
php-5.3.3-48.el6_8.x86_64
php-gd-5.3.3-48.el6_8.x86_64
php-xml-5.3.3-48.el6_8.x86_64
php-pdo-5.3.3-48.el6_8.x86_64
php54-php-cli-5.4.40-4.el6.x86_64
php54-php-mbstring-5.4.40-4.el6.x86_64
[root@teapage ~]# yum -y update php*
Loaded plugins: fastestmirror, presto
Setting up Update Process
Loading mirror speeds from cached hostfile
 * epel: mirror.imt-systems.com
No Packages marked for Update
# php -v
PHP 5.3.3 (cli) (built: Aug 11 2016 20:33:53)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
# cat /var/log/yum.log
Mar 10 00:50:36 Installed: centos-release-scl-rh-2-3.el6.centos.noarch
Mar 10 00:51:06 Installed: scl-utils-20120927-27.el6_6.x86_64
Mar 10 00:51:13 Installed: php54-runtime-2.0-1.el6.x86_64
Mar 10 00:51:13 Installed: php54-php-common-5.4.40-4.el6.x86_64
Mar 10 00:51:14 Installed: php54-php-cli-5.4.40-4.el6.x86_64
Mar 10 00:51:14 Installed: php54-php-process-5.4.40-4.el6.x86_64
Mar 10 00:51:14 Installed: php54-php-xml-5.4.40-4.el6.x86_64
Mar 10 00:51:14 Installed: 1:php54-php-pear-1.9.4-10.sc1.el6.noarch
Mar 10 00:51:14 Installed: t1lib-5.1.2-6.el6_2.1.x86_64
Mar 10 00:51:14 Installed: php54-php-gd-5.4.40-4.el6.x86_64
Mar 10 00:51:15 Installed: php54-2.0-1.el6.x86_64
Mar 10 00:51:15 Installed: php54-php-5.4.40-4.el6.x86_64
Mar 10 00:51:15 Installed: php54-php-mbstring-5.4.40-4.el6.x86_64
Mar 10 00:51:32 Installed: php54-php-pdo-5.4.40-4.el6.x86_64
Mar 10 00:51:32 Installed: php54-php-mysqlnd-5.4.40-4.el6.x86_64

Помогите пожалуйста удалть php 5.4 и не накосячить


Вчера один скрипт новой версии написал что ему надо php 5.4
новой версии

...

17 Feb 2017: PHP 7.1.2 Released
5.4 unsupported since 3 Sep 2015
5.5 unsupported since 21 Jul 2016

KRoN73 ★★★★★ ()
Последнее исправление: KRoN73 (всего исправлений: 1)

Теперь тебе надо удалить все зависимости которые потянули пакеты с php 5.4 Далее удалить репозиторий с PHP 5.4

После чего установить стандартный PHP c официального репозитория.

AlfaStriker ()
sudo yum history list

смотришь какая из этих операций установка php 5.4 и запоминаешь ее номер, а затем:

sudo yum history undo номер_операции
смотришь список удаляемых пакетов, и если все ок, то жмешь Y, Enter

r0ck3r ★★★★★ ()
Последнее исправление: r0ck3r (всего исправлений: 1)

За удаление у yum отвечает команда «remove», «update» — это обновление пакетов.

berrywizard ★★★★★ ()

хочу удалить php 5.4

Может удалить php 5.3?

goingUp ★★★★★ ()
Ответ на: комментарий от goingUp

Тогда он будет удивляться, куда похапэ вообще пропало, ведь 5.4 он ставил из SCL, при этом явно не в курсе, что это.

anonymous ()
Ответ на: комментарий от goingUp

А как поставить на ценось последнюю стабильную версию пхп если ее нету в стандартных репозиториях? Подключать хрен пойми какой репозиторий, который скомпилил вася-тру-админ, и потом куча зависимостей будет установлена, в результате сервер надо будет переустанавливать. Поставить что то из непонятного репозитория, накатить зависимости, это единственный способ убить центось, по другому я ее не убивал за 10 лет использования.

Eof ()
Ответ на: комментарий от KRoN73

Ололоша, скрипт более новой версии, требует более свежей php. В любом случае, отличная шутка.

Eof ()
Ответ на: комментарий от Eof

хрен пойми какой репозиторий, который скомпилил вася-тру-админ
в результате сервер надо будет переустанавливать
переустанавливать
сервер

Так это ты вася-тру-админ шоли?

по другому я ее не убивал за 10 лет использования

Конечно, ведь ты ее и не использовал 10 лет.

slaykovsky ★★★ ()
Ответ на: комментарий от Eof

Он тебе про то, что жить надо в настоящем времени, а не использовать deprecated мусор.

slaykovsky ★★★ ()
Ответ на: комментарий от Eof

Мам, я еще за компом посижу немного. В интеренете опять кто-то не прав!

slaykovsky ★★★ ()
Ответ на: комментарий от slaykovsky

Это твои чувства, тебе их проживать. Твое непринятие людей это совсем не моя история.

Eof ()
Ответ на: комментарий от Eof

и зачем нужно грубить, когда вам дают здравые рекомендации? по вашим проблемам совсем не похоже, что вы умеете администрировать CentOS,а уж тем более 10 лет ей пользовались (или вы за 10 лет ничему не научились?)

anonymous ()
Ответ на: комментарий от Eof

Системный администратор должен уметь гуглить. Когда я последний раз видел SCL, там надо было запускать программы через специальный враппер. Это сделано чтобы ничего не поломалось от внезапной замены GCC 4 на GCC 6.

anonymous ()
Ответ на: комментарий от anonymous

потому что жизнь стабильная

если кого обидел извините

спасибо за оценку

Eof ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.