LINUX.ORG.RU
решено ФорумAdmin

Samba и доменные группы, нет доступа.

 


1

1

Доброго времени всем!!! Образовалась необходимость поднять шару для доменной группы, реши сделать на Centos 6.8. Samba настроили, в домен ввели, доменной учеткой в систему захожу. wbinfo -u, wbinfo -g, getent passwd, getent group работают. Дал права на нужную папку (acl так же накинул на доменную группупу rwx). Локально из под доменной учетки в этой папке могу все. При подключении из win7 ч\з net use папка цепляется, однако при попытке, что либо сделать, говорит нет доступа.

Есть ли идей в какую сторону капать?

Сейчас пишу из дома и показать конфиги не могу, скину их завтра.


За одно и логи клиента из папки самбы

jasper88 ()

Давай больше информации, включая конфиг самбы.
Клиент win7 в домене, учётка используется та же, другая не сохранена для этой шары? Selinux не ругается?

gasinvein ★★★ ()
Последнее исправление: gasinvein (всего исправлений: 1)
Ответ на: комментарий от gasinvein

И так, win7 в домене, учетка та же.

[root@FileServer ~]# getent passwd 0005LOCALRU\\d30oit05 0005LOCALRU\d30oit05:*:16777219:16777222:Иванов Иван Иванович:/home/0005LOCALRU/d30oit05:/bin/bash [root@FileServer ~]# getent group 0005LOCALRU\\oit_otd 0005LOCALRU\oit_otd:*:16777224:0005LOCALRU\d30oit05 [root@FileServer ~]# getfacl /shares/zakupki/ getfacl: Removing leading '/' from absolute path names # file: shares/zakupki/ # owner: root # group: 0005LOCALRU\134oit_otd # flags: -s- user::rwx group::rwx group:0005LOCALRU\134oit_otd:rwx mask::rwx other::---

[root@FileServer ~]# ll -d /shares/zakupki/ drwxrws---+ 3 root 0005LOCALRU\oit_otd 4096 Мар 7 11:49 /shares/zakupki/ [root@FileServer ~]# testparm Load smb config files from /etc/samba/smb.conf Processing section "[zakupki]" Loaded services file OK. Server role: ROLE_DOMAIN_MEMBER Press enter to see a dump of your service definitions

[global] workgroup = 0005LOCALRU realm = 0005.LOCAL.RU server string = Samba Server Version %v security = ADS auth methods = winbind allow trusted domains = No obey pam restrictions = Yes log file = /var/log/samba/log.%m max log size = 50 client signing = required template shell = /bin/bash winbind enum users = Yes winbind enum groups = Yes winbind refresh tickets = Yes idmap config * : range = 16777222-16778222 idmap config * : backend = rid map acl inherit = Yes cups options = raw

[zakupki] comment = zakupki path = /shares/zakupki valid users = @0005LOCALRU\oit_otd write list = @0005LOCALRU\oit_otd inherit permissions = Yes inherit acls = Yes inherit owner = Yes [root@FileServer ~]#

Не понял почему сейчас getfacl показывает 0005LOCALRU\134oit_otd, еще во вторник отображалось 0005LOCALRU\oit_otd

guzya ()
Ответ на: комментарий от guzya

Попробуй убрать valid users и write list.

getfacl показывает 0005LOCALRU\134oit_otd

«\134» это escape-последовательность для «\»
И используй тег [code][/code]

gasinvein ★★★ ()
Последнее исправление: gasinvein (всего исправлений: 1)

конфиг самба нужен.

auth methods = winbind ?

пользователи в самбу подмаплены?

P.s PAM для samba сам не прописывается в Centos.

bkmz12332 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.