LINUX.ORG.RU
ФорумAdmin

«WARNING: failed to start smbd»

 , ,


0

2

Доброго времени всем! Столкнулся с утра с ситуёвиной. После воскресного автоматического обновления, перестал запускаться сервер samba установленный на FreeBSD 10.0. При попытке запуска вручную:

# service samba_server restart

Performing sanity check on Samba configuration: OK

smbd not running? (check /var/run/samba4/smbd.pid).

Stopping nmbd.

Waiting for PIDS: 1227.

Performing sanity check on Samba configuration: OK

Starting nmbd.

Starting smbd.

/lib/libc.so.7: version FBSD_1.4 required by /usr/local/lib/samba4/private/libsmbd-base-samba4.so not found

/usr/local/etc/rc.d/samba_server: WARNING: failed to start smbd

libsmbd-base-samba4.so - лежит где и положено, freebsd-update fetch не помог.

samba установленный на FreeBSD 10.0

А на какую версию обновился писать не надо?

freebsd-update fetch

А инсталлить обновления не пробовал?

/lib/libc.so.7: version FBSD_1.4 required

Обновили libc, видимо, самбу пересобери.

r3lgar ★★★★★ ()
Ответ на: комментарий от r3lgar

Это то, что обновилось вчера на серверах:

Installed packages to be UPGRADED:
bash: 4.4.11 -> 4.4.12
bind99: 9.9.9P5_1 -> 9.9.9P6
ca_root_nss: 3.28.1 -> 3.29
e2fsprogs-libuuid: 1.43.3_1 -> 1.43.4
gmp: 5.1.3_3 -> 6.1.2
lha: 1.14i_6 -> 1.14i_7
libevent2: 2.0.22_1 -> 2.1.8
libnghttp2: 1.18.1 -> 1.19.0
libuv: 1.10.2 -> 1.11.0
mysql56-client: 5.6.35_1 -> 5.6.35_2
mysql56-server: 5.6.35_3 -> 5.6.35_4
nghttp2: 1.18.1 -> 1.19.0_1
pcre: 8.39_1 -> 8.40
pkgconf: 1.2.0_2 -> 1.2.2_1
png: 1.6.27 -> 1.6.28
py27-MarkupSafe: 0.23 -> 0.23_1
py27-glances: 2.7.1 -> 2.8.1
py27-psutil: 5.0.1 -> 5.1.3
py27-pygments: 2.1.3 -> 2.1.3_1
ruby: 2.3.3_1,1 -> 2.3.3_2,1
spdylay: 1.4.0_1 -> 1.4.0_2
unbound: 1.6.0 -> 1.6.0_1
xorg-macros: 1.19.0 -> 1.19.1

Сама Samba не обновлялась (возможно неверно написал в начале)
# smbclient -V
Version 4.4.8
После обновлений сервера перезагружены, проблема вылезла уже сегодня.

По стандарту:
#freebsd-update fetch
#freebsd-update install
#shutdown -r now

DesCod ()
Ответ на: комментарий от DesCod

Это то, что обновилось вчера на серверах:

Так libc — часть базовой системы, его не будет в списке.

Сама Samba не обновлялась

Потому я тебе и говорю, что, возможно, её следует пересобрать, так как она слинкована на libc, а он, судя по всему, обновился. freebsd-version я так и не увидел, потому остаётся только гадать.

r3lgar ★★★★★ ()
Последнее исправление: r3lgar (всего исправлений: 1)
Ответ на: комментарий от r3lgar

всё хорошо... но не очень:

# cd /usr/ports/net/samba44/
# make clean
# make && make install clean && rehash

===> samba44-4.4.8 cannot install: SASL support requested and openldap-client-2.4.44 is installed.
*** Error code 1

DesCod ()
Ответ на: комментарий от DesCod

Ну сделай pkg delete samba44 && pkg autoremove && make install clean -C /usr/ports/net/samba44/

IPR ★★★★★ ()
Ответ на: комментарий от DesCod

Может ты осилишь уже чтение сообщений об ошибках или тебе перевод каждой нужен?

zgen ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.