LINUX.ORG.RU

Проблема автозапуска Nginx с SSL при использовании несколько IP

 , ,


0

1

День добрый! После добавления сайтов с ssl с привязкой на IP Nginx перестал загружаться при reboot. В конфиге Nginx

   server {
       listen _IP_:443;
       server_name _domen_:443;
       ssl on;
   ...
В логах ошибка
bind() to _IP_:443 failed (99: Cannot assign requested address)
Если после этого перезапустить руками - запускается без ошибок. Если изменить конфиг без указания IP - автозагрузка без ошибок (не подходит, т.к. надо использовать ssl на несколько IP
   server {
       listen 443;
       server_name _domen_:443;
       ssl on;
   ...
Возможно проблема в том, что на момент автозапуска Nginx еще не поднялся сетевой адрес. Это как-то можно определить и вылечить? Возможно указать поднятие Nginx только после всех сетевых интерфейсов? CentOS-7, Nginx 1.6.3

Если сетью рулит network manager, то можно попробовать systemctl enable NetworkManager-wait-online.service

Deleted ()

Можно попробовать прописать в файле запуска nginx.service (где-то в /etc/systemd/)

After=network.target

в секции [Unit]

mrv78 ()
Ответ на: комментарий от thematt

различные не дефолтные опции лучше прописывать в /etc/systemd/system/nginx.service.d/someopt.conf, чтобы не потерлись при обновлении.

thematt ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.