LINUX.ORG.RU
ФорумAdmin

udev 225 (не работает 80-net-setup-link.rules )

 , ,


0

1

Прошу помощи :
После обновления системы (gentoo) версия udev стала 225 и следом за этим после перезагрузки сетевые интерфейсы стали менять имена местами.
Привязка Mac адресов естественно не помогла но частично решила проблемы, так как провайдер использует привязку со своей стороны.
В системе 4 eth* интерфейса и после перезагрузки приходиться наугад переподключать кабели.
Файл /etc/udev/rules.d/80-net-setup-link.rules :
SUBSYSTEM==«net», ACTION==«add», ATTR{address}==«aa:bb:14:13:12:11», NAME=«eth0»
SUBSYSTEM==«net», ACTION==«add», ATTR{address}==«aa:bb:14:13:12:12», NAME=«eth1»
SUBSYSTEM==«net», ACTION==«add», ATTR{address}==«aa:bb:14:13:12:13», NAME=«eth2»
SUBSYSTEM==«net», ACTION==«add», ATTR{address}==«aa:bb:14:13:12:14», NAME=«eth3»
Подскажите в какую сторону читать\копать. Спасибо!


LORcode отменили, или ты какой-то избранный?

Пробежался по твоим тредам — ни один не оформлен должным образом.

r3lgar ★★★★★ ()
Последнее исправление: r3lgar (всего исправлений: 3 )

Удали этот файл и используйте новые имена интерфейсов.

imul ★★★★★ ()

Удали файл и используй net.ifnames=0 в параметрах загрузки.

TaV0x222 ()

Переименование без race conditions возможно в имена отличные от тех, которые присваивает ядро. eth* - не взлетит. Я использую lan* например.

Ну и да, про net.ifnames=0 уже сказали

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Благодарю всех за советы, за LORcode прошу прощения!

zema ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.