LINUX.ORG.RU
ФорумAdmin

https не работает для Opera, только для IE


0

0

Ставлю на один из виртуальных серверов SSL авторизацию. Пересобрал Апач, сгенерил сертификаты. Через IE нормально заходит, показывает данные сертификата, а через Оперу - висит, и ошибка (110) Connection timed out.
Чувствую, что напортачил в конфиге Апача, но вот где ?
---- httpd.conf -----
.....
<IfDefine SSL>
Listen 80
Listen 443
</IfDefine>
.....
<IfDefine SSL>
AddType application/x-x509-ca-cert .crt
AddType application/x-pkcs7-crl .crl
</IfDefine>
.....
<IfModule mod_ssl.c>
SSLPassPhraseDialog builtin
SSLSessionCache dbm:/usr/local/apache/logs/ssl_scache
SSLSessionCacheTimeout 300
SSLMutex file:/usr/local/apache/logs/ssl_mutex
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
SSLLog /var/log/httpd/ssl_engine_log
SSLLogLevel info
</IfModule>
.....
# Дальше описания серверов
.....
<IfDefine SSL>
NameVirtualHost www.server.ru:443
<VirtualHost www.server.ru:443>
ServerAdmin admin@server.ru
DocumentRoot /home/httpd/server.ru/html
ServerName www.server.ru
ServerAlias og.server.ru
ServerAlias server.ru
SSLEngine on
SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
SSLCertificateFile /usr/local/apache/conf/ssl.crt/slonru.crt
SSLCertificateKeyFile /usr/local/apache/conf/ssl.key/slonru.key
SSLCACertificateFile /usr/local/apache/conf/slonru-ca.crt
SSLCARevocationFile /usr/local/apache/conf/ssl.crl/slonru.crl
SSLOptions +StdEnvVars
SetEnvIf User-Agent ".*MSIE.*" \ nokeepalive ssl-unclean-shutdown \ downgrade-1.0 force-response-1.0

ErrorLog /var/log/httpd/server.ru.error_log
CustomLog /var/log/httpd/server.ru.access_log combined
ScriptAlias /cgi/ /home/httpd/server.ru/cgi/
ScriptAlias /cgi-bin/ /home/httpd/server.ru/cgi-bin/
ScriptAlias /cgi-admin/ /home/httpd/server.ru/cgi-admin/
ScriptAlias /forum/ /home/httpd/server.ru/forum/

<Directory /home/httpd/server.ru/html>
SSLRequireSSL
SSLOptions +FakeBasicAuth +StrictRequire
Options Indexes Includes
AllowOverride FileInfo AuthConfig
order allow,deny
allow from all
</Directory>

<Directory /home/httpd/og3.boston.ru/cgi>
AllowOverride FileInfo AuthConfig
Options SymLinksIfOwnerMatch ExecCGI
</Directory>
</VirtualHost>

В логах ничего при коннекте оперой... Хэлп !


Re: https не работает для Opera, только для IE

Проблема решилась просто - установкой галки "ходить через прокси" для HTTPS (в IE такая галка была :)

Yakuza ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.