LINUX.ORG.RU
ФорумAdmin

Apache: HostnameLookup On не работает


0

0

На компе установлен bind, резолвинг происходит нормально, но Apache не пишет в логи доменное имя, в чем может быть причина?

Конфиг:

ServerRoot "/usr/local/apache2" Listen 80

<IfModule !mpm_winnt_module> <IfModule !mpm_netware_module> User www Group www </IfModule> </IfModule>

ServerAdmin webmaster@domain.ru ServerName www.domain.ru:80 DocumentRoot "/usr/local/apache2/htdocs"

<Directory /> Options None AllowOverride None Order deny,allow Deny from all </Directory>

<Directory "/usr/local/apache2/htdocs"> Options Indexes FollowSymLinks AllowOverride None Order allow,deny Allow from all </Directory>

<Directory "/usr/local/apache2/htdocs/linux"> HostnameLookups On </Directory>

<IfModule dir_module> DirectoryIndex index.html index.htm Index.html Index.htm </IfModule>

<FilesMatch "^\.ht"> Order allow,deny Deny from all </FilesMatch>

HostnameLookups On

ErrorLog logs/error_log LogLevel debug

<IfModule log_config_module> LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined LogFormat "%h %l %u %t \"%r\" %>s %b" common <IfModule logio_module> LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio </IfModule>

CustomLog logs/access_log common

</IfModule>

<IfModule alias_module> ScriptAlias /cgi-bin/ "/usr/local/apache2/cgi-bin/" </IfModule>

<IfModule cgid_module> </IfModule>

<Directory "/usr/local/apache2/cgi-bin"> AllowOverride None Options None Order allow,deny Allow from all </Directory>

DefaultType text/plain

<IfModule mime_module> TypesConfig conf/mime.types AddType application/x-compress .Z AddType application/x-gzip .gz .tgz </IfModule>

<IfModule ssl_module> SSLRandomSeed startup builtin SSLRandomSeed connect builtin </IfModule>

Alias /perl/ /usr/local/apache2/perl/ <Location /perl/> SetHandler perl-script PerlResponseHandler ModPerl::Registry PerlOptions +ParseHeaders Options +ExecCGI Order allow,deny Allow from all </Location>

anonymous

Re: Apache: HostnameLookup On не работает

Сорри за вид, еще раз

ServerRoot "/usr/local/apache2"
Listen 80

<IfModule !mpm_winnt_module>
<IfModule !mpm_netware_module>
User www
Group www
</IfModule>
</IfModule>

ServerAdmin webmaster@domain.ru
ServerName www.domain.ru:80
DocumentRoot "/usr/local/apache2/htdocs"

<Directory />
Options None
AllowOverride None
Order deny,allow
Deny from all
</Directory>


<Directory "/usr/local/apache2/htdocs">
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
</Directory>

<Directory "/usr/local/apache2/htdocs/linux">
HostnameLookups On
</Directory>

<IfModule dir_module>
DirectoryIndex index.html index.htm Index.html Index.htm
</IfModule>

<FilesMatch "^\.ht">
Order allow,deny
Deny from all
</FilesMatch>

HostnameLookups On

ErrorLog logs/error_log
LogLevel debug

<IfModule log_config_module>
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
<IfModule logio_module>
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
</IfModule>

CustomLog logs/access_log common

</IfModule>

<IfModule alias_module>
ScriptAlias /cgi-bin/ "/usr/local/apache2/cgi-bin/"
</IfModule>

<IfModule cgid_module>
</IfModule>

<Directory "/usr/local/apache2/cgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

DefaultType text/plain

<IfModule mime_module>
TypesConfig conf/mime.types
AddType application/x-compress .Z
AddType application/x-gzip .gz .tgz
</IfModule>

<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
</IfModule>

Alias /perl/ /usr/local/apache2/perl/
<Location /perl/>
SetHandler perl-script
PerlResponseHandler ModPerl::Registry
PerlOptions +ParseHeaders
Options +ExecCGI
Order allow,deny
Allow from all
</Location>

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.