LINUX.ORG.RU
ФорумAdmin

Не заводится tftpd под Debian

 ,


0

2

ткните мордой, что не так!

Установил:

apt install tftpd tftp

он сам подтащил openbsd-inetd, далее я его полез настраивать в файл /etc/inetd.conf

Там секция, отвечающая за tftp появилась сама и я ничего не трогал

#:BOOT: TFTP service is provided primarily for booting.  Most sites
#       run this only on machines acting as "boot servers."
tftp            dgram   udp     wait    nobody  /usr/sbin/tcpd  /usr/sbin/in.tftpd /srv/tftp

на директорию /srv/tftp установил владельца nobody и права 777

перезапустил openbsd-inetd

проверил слушается ли порт:

$ netstat -anp | grep 69
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
udp        0      0 0.0.0.0:69              0.0.0.0:*                           -               
unix  3      [ ]         STREAM     CONNECTED     23569    1891/pulseaudio     
unix  3      [ ]         STREAM     CONNECTED     22694    -                   @/tmp/.X11-unix/X0
unix  3      [ ]         STREAM     CONNECTED     21693    1837/xfce4-session  @/tmp/.ICE-unix/1837
unix  2      [ ]         STREAM     CONNECTED     20069    -                   @/tmp/dbus-2k8n7tBl
unix  3      [ ]         STREAM     CONNECTED     22569    -                   /run/systemd/journal/stdout
unix  2      [ ]         DGRAM                    21569    -                   
unix  3      [ ]         STREAM     CONNECTED     34698    5214/chrome         
unix  3      [ ]         STREAM     CONNECTED     22692    1827/dbus-daemon    @/tmp/dbus-Gqq8iiTZXZ
unix  3      [ ]         STREAM     CONNECTED     35669    -                   @/tmp/.X11-unix/X0
unix  3      [ ]         STREAM     CONNECTED     17769    -                   
unix  3      [ ]         STREAM     CONNECTED     17569    -                   
unix  3      [ ]         STREAM     CONNECTED     34697    5214/chrome   

положил туда (/srv/tftp/) файлик hello.txt c содержанием sdfsdfsdfsd

подключаюсь tftp localhost

командую get hello.txt — бьюсь бошкой об таймаут

эни айдиас? спасибо

★★★★★

Он же может сам без inetd работать. И в init.d скрипт есть.

# /etc/default/tftpd-hpa
TFTP_USERNAME="tftp"
TFTP_DIRECTORY="censored"
TFTP_ADDRESS="0.0.0.0:69"
TFTP_OPTIONS="-v --secure -B 1468"

На директорию поставил права 755. Сетевая загрузка работает нормально на машинах.

Radjah ★★★★★ ()
Ответ на: комментарий от anonymous

В логи смотри

Всю башку сломал ища у него логи :) в итоге tcpdump-ом обхожусь

И секцию SECURITY в man in.tftpd

Нету там такой секции :(

pihter ★★★★★ ()
Ответ на: комментарий от anonymous

Советую поставить atftpd. У tftpd какая-то родовая травма с PUT/GET.

На настольном компе все то же самое сделал — отлично работает. А на буке никак. А бук удобный: его к железякам таскать легко

pihter ★★★★★ ()
Ответ на: комментарий от Deleted

На файлик то права дать небось забыл ?

не. Да говорю ж: на компе работает, а на буке — ни в какую. Все сравнил — все одинаковое...

pihter ★★★★★ ()
Ответ на: комментарий от Radjah

Поставил tftpd-hpa...

то же самое!!! сервер запускается (в логах вижу, порт висит) но файл не отдает по тайм-ауту... хм...

pihter ★★★★★ ()
Ответ на: комментарий от pihter

Сервер работает, но файл не отдает!

tftp
(to) 
usage: connect host-name [port]
tftp> 
tftp> status 
Not connected.
Mode: netascii Verbose: off Tracing: off Literal: off
Rexmt-interval: 5 seconds, Max-timeout: 25 seconds
tftp> 
tftp> 
tftp> connect localhost
tftp> 
tftp> status
Connected to localhost.
Mode: netascii Verbose: off Tracing: off Literal: off
Rexmt-interval: 5 seconds, Max-timeout: 25 seconds
tftp> 
tftp> get 1.txt
Transfer timed out.

tftp> 

права на файл:

 ls -l /srv/tftp
итого 0
-rwxrwxrwx 1 tftp tftp 0 ноя 16 18:27 1.txt

настройки сервера:

cat /etc/default/tftpd-hpa 
# /etc/default/tftpd-hpa

TFTP_USERNAME="tftp"
TFTP_DIRECTORY="/srv/tftp"
TFTP_ADDRESS="0.0.0.0:69"
TFTP_OPTIONS="--secure --permissive"

pihter ★★★★★ ()
Ответ на: комментарий от Radjah

Дополнительные записи в логе действительно появились :)

# cat /var/log/daemon.log | grep ftp
Nov 17 08:16:49 max-book tftpd-hpa[27353]: Stopping HPA's tftpd: in.tftpd.
Nov 17 08:16:49 max-book tftpd-hpa[27358]: Starting HPA's tftpd: in.tftpd/usr/sbin/in.tftpd: unrecognized option '--vvv'
Nov 17 08:16:49 max-book in.tftpd[27363]: Unknown option: '
Nov 17 08:16:49 max-book tftpd-hpa[27358]: .

Ну и вот сам конфиг, на всякий случай:

# /etc/default/tftpd-hpa
TFTP_USERNAME="tftp"
TFTP_DIRECTORY="/srv/tftp"
TFTP_ADDRESS="0.0.0.0:69"
TFTP_OPTIONS="--secure --permissive --vvv"

Пойду гуглить про опции

pihter ★★★★★ ()
Ответ на: комментарий от Radjah

Лишний минусик перед vvv! Пардон: был напуган!

Однако, не помогло!

В логах только старт-стоп а файл все не отдает!

Nov 17 08:39:48 max-book tftpd-hpa[27931]: Stopping HPA's tftpd: in.tftpd.
Nov 17 08:39:48 max-book tftpd-hpa[27935]: Starting HPA's tftpd: in.tftpd.

pihter ★★★★★ ()
Ответ на: комментарий от pihter

Ты посмотри в /var/log/daemon.log. Туда обычно пишется всё. tftpd в syslog только умеет.

В совсем крайнем случае придется tcpdump-ом тыкать.

Radjah ★★★★★ ()

Добавить права доступа на чтение, начиная от корня и рекурсивно вплоть до конечного файла, для юзера/группы под которыми работает сервис.
И для фаервола нужно дополнительно подгрузить nf_conntrack_tftp, а если через шлюз, то ещё nf_nat_tftp.

ArcFi ()
Ответ на: комментарий от Radjah

Да я его и смотрю. Ниче не пишет. Только старт и стоп.

cat /var/log/daemon.log | grep ftp
Nov 15 08:30:06 max-book tftpd-hpa[709]: Starting HPA's tftpd: in.tftpd.
Nov 16 08:36:56 max-book tftpd-hpa[713]: Starting HPA's tftpd: in.tftpd.
Nov 16 08:39:20 max-book tftpd-hpa[2305]: Stopping HPA's tftpd: in.tftpd.
Nov 16 14:41:27 max-book tftpd[752]: unknown option -?
Nov 16 14:41:27 max-book tftpd-hpa[709]: Starting HPA's tftpd: in.tftpd
Nov 16 14:41:27 max-book systemd[1]: tftpd-hpa.service: control process exited, code=exited status=1
Nov 16 14:41:27 max-book systemd[1]: Failed to start LSB: HPA's tftp server.
Nov 16 14:41:27 max-book systemd[1]: Unit tftpd-hpa.service entered failed state.
Nov 16 17:50:40 max-book tftpd-hpa[6094]: Starting HPA's tftpd: in.tftpd.
Nov 16 17:51:04 max-book tftpd-hpa[6188]: Stopping HPA's tftpd: in.tftpd.
Nov 16 17:51:36 max-book tftpd-hpa[6883]: Starting HPA's tftpd: in.tftpd.
Nov 16 17:54:38 max-book tftpd-hpa[6992]: Stopping HPA's tftpd: in.tftpd.
Nov 16 17:54:38 max-book tftpd-hpa[6997]: Starting HPA's tftpd: in.tftpd.
Nov 16 17:57:37 max-book tftpd-hpa[8217]: Stopping HPA's tftpd: in.tftpd.
Nov 16 17:57:37 max-book tftpd-hpa[8222]: Starting HPA's tftpd: in.tftpd.
Nov 17 08:16:49 max-book tftpd-hpa[27353]: Stopping HPA's tftpd: in.tftpd.
Nov 17 08:16:49 max-book tftpd-hpa[27358]: Starting HPA's tftpd: in.tftpd/usr/sbin/in.tftpd: unrecognized option '--vvv'
Nov 17 08:16:49 max-book in.tftpd[27363]: Unknown option: '
Nov 17 08:16:49 max-book tftpd-hpa[27358]: .
Nov 17 08:39:48 max-book tftpd-hpa[27931]: Stopping HPA's tftpd: in.tftpd.
Nov 17 08:39:48 max-book tftpd-hpa[27935]: Starting HPA's tftpd: in.tftpd.
pihter ★★★★★ ()
Ответ на: комментарий от ArcFi

Добавить права доступа на чтение, начиная от корня и рекурсивно вплоть до конечного файла, для юзера/группы под которыми работает сервис.

root@max-book:/# chmod 777 /var
root@max-book:/# chmod 777 /var/tftp/
root@max-book:/# chmod 777 /var/tftp/hello.txt 
root@max-book:/# /etc/init.d/tftpd-hpa restart
[ ok ] Restarting tftpd-hpa (via systemctl): tftpd-hpa.service.
root@max-book:/# tftp localhost
tftp> get hello.txt
Transfer timed out.

tftp> 

И для фаервола нужно дополнительно подгрузить nf_conntrack_tftp, а если через шлюз, то ещё nf_nat_tftp.

ЯННП :)

pihter ★★★★★ ()
Ответ на: комментарий от ArcFi

Что говорит мануал по этому сервису на предмет повышения уровня логирования?

выдержка из man in.tftpd

--verbose, -v
              Increase the logging verbosity of tftpd.  This flag can be specified multiple times for even higher verbosity.

--verbosity value
              Set the verbosity value to value.

Выше, Radjah уже советовал и я уже сделал.

pihter ★★★★★ ()
Ответ на: комментарий от ArcFi

Пардон: был напуган!

root@max-book:/# chmod 777 /srv/
root@max-book:/# chmod 777 /srv/tftp/
root@max-book:/# chmod 777 /srv/tftp/1.txt 
root@max-book:/# /etc/init.d/tftpd-hpa restart
[ ok ] Restarting tftpd-hpa (via systemctl): tftpd-hpa.service.
root@max-book:/# tftp localhost
tftp> get 1.txt
Transfer timed out.

tftp> 

так не лучше (

pihter ★★★★★ ()
Ответ на: комментарий от pihter

SELinux/AppArmor?
Убедитесь, что нет помех со стороны фаервола:

sudo iptables-save

Проверьте общесистемные логи (запустить перед попыткой подключения, смотреть после):
sudo tail -f /var/log/* 2>/dev/null

ArcFi ()
Ответ на: комментарий от ArcFi

Я тогда не заметил сообщения, но спасибо за советы. (негоже помощь без ответа оставлять)

pihter ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.