LINUX.ORG.RU
ФорумAdmin

Настройка прав в NFS (4)

 , ,


0

3

Доброго дня, котаны.

Направьте меня на путь истинный, может я криворукий.

Есть сервер(centos 6.8) NFS. Файл /etc/exportfs такой:

/mnt/share 10.2.10.0/24 (rw,no_root_squash)

Монтирую клиентом

mount <server_ip>:/mnt/share/ /mnt/share

И у меня права на этот каталог стоят, например: nobody:nogroup А мне надо <username>:<usergroup>

Делал так

chown <username>:<usergroup> /mnt/share

Как до монтирования, так после. Результат один - nobody:nogroup

Как мне выставить клиентские права на примонтированный каталог?

Пробел убери между подсетью и опциями.

Deleted ()

Подписываюсь. В своё время не смог решить эту задачу. Напиши, пожалуйста, решение, как найдешь.

Kroz ★★★★★ ()
Последнее исправление: Kroz (всего исправлений: 1 )
Ответ на: man 5 exports от mos

Это, конечно, классно.

А как сделать, чтобы пользователь с ID=1000 на 10.0.0.1 клиенте мапился на ID=2000 на NFS сервере?

Kroz ★★★★★ ()
Ответ на: комментарий от mos

какие еще пожелания, о волька ибн алеша?

Эххх... А счастье казалось так близко...

Kroz ★★★★★ ()
Ответ на: комментарий от false

all_squash?

man 5 exports
all_squash - Map all uids and gids to the anonymous user. Useful for NFS-exported public FTP directories, news spool directories, etc. The opposite option is no_all_squash, which is the default setting.
Наоборот, хочется чтобы юзеры:группы сохранялись. Проблема в том, что ID юзера user1 на клиенте 1000, а на сервере 2000. Нужен маппинг ID'шек на клиенте и сервере.

Цель - бекап с помощью rsync.

Kroz ★★★★★ ()
Ответ на: комментарий от false

если quick and dirty да
если местным икспердам нужно потяжелее, то централизованная база.

mos ★★☆☆☆ ()
Ответ на: комментарий от TEX

не понял, а как это решит пролему *маппинга* пользователя 1000 на клиенте в пользователя 2000 на сервере?

mos ★★☆☆☆ ()

xalexbor, сорри, что я так вклиниваюсь в твой топик, но, как мне кажется, мои вопросы помогут и тебе.

Как я понимаю, чтобы у тебя всё работало, нужно чтобы user ID и group ID (имено ID) для твоих group и user совпадали. Попробуй. А более правильная альтернатива - user ID mapping, про что я сейчас и спрашиваю народ.

Kroz ★★★★★ ()
Последнее исправление: Kroz (всего исправлений: 1 )
Ответ на: комментарий от TEX

Спасибо за хинт, посмотрю на досуге.

Kroz ★★★★★ ()
Ответ на: комментарий от Kroz

Ты это делал, малыш?

echo 'N' > /sys/module/nfs/parameters/nfs4_disable_idmapping
nfsidmap -c 
service rpcidmapd restart

man rpc.idmapd

futurama ★★★★★ ()
Ответ на: комментарий от Kroz

ID=1000 на 10.0.0.1 клиенте мапился на ID=2000

На сервере под id=2000 должен быть тот же пользователь, что и на клиенте с ID=1000. Т.е. имя должно быть такое же, а UID неважен, будет мапиться (см. также пред. сообщение)

futurama ★★★★★ ()
Ответ на: комментарий от mos

Это не решает проблему маппинга, это помогает понять одну из причин почему маппинг может не работать.

Потому что в старых ядрах, например для 6-й rhel, маппинг по умолчанию разрешен, а в новых, например для 7-й rhel, ровно наоборот.

В зависимости от того какое ядро у тебя на клиенте, а какое на сервер - один и тот же конфиг может быть как с работающим маппингом, так и неработающим.

А так для корректного маппинга нужно еще idmapd.conf курить

TEX ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.