LINUX.ORG.RU

nfs4&Centos5.3-5.5


0

1

Приветствую! Столкнулся со следующей проблемой. Есть сервер, на котором стоит CentOS 5.3. С него на клиентов по nfs3 монтируются два раздела. Появилась необходимость монтировать по nfs4 Вкратце последовательность действий на сервере:

1. yum install nfs-utils nfs4-acl-tools portmap
 service nfs restart
 service portmap restart
 service iptables stop
 # cat /etc/exports
 #
 /  *(rw,insecure,fsid=0,no_root_squash)
 /d01 *(rw,insecure,fsid=1,no_root_squash)
 /d02 *(rw,insecure,fsid=2,no_root_squash)
  exportfs -r

На клиенте (Centos 5.5.):

mkdir -m777 /d01
mount -t nfs4 server:/d01 /d01
Команда монтирования отрабатывается, по df диск отображается, но! размер диска и процент использования - абсолютно неправильный и соотвтетственно не отображаются файлы и каталоги, которые на этом разделе располагаются. Если монтировать mount server:/d01 /d01 то всё путем. Вопрос знактокам, где косяки порылись?:) p/s Конфигурация тестовая, в плане приведенных настроек nfs4 (эт я к тому, что корень диска в exports)


Попробуйте убрать строчку с fsid=0. d01 и d02 это разные файловые системы или разные каталоги на одной файловой системе?

mky ★★★★★ ()
Ответ на: комментарий от Stag

Я выпил пива и вопроизвёл вашу ситуацию. В общем, строку с fsid=0 оставьте, а к описанию d01 и d02 добавьте опцию «nohide». У меня заработало как надо. Почему --- незнаю.

mky ★★★★★ ()
Ответ на: комментарий от mky

Спасибо, мудрый человек, заработало! Изучу вопрос - «почему» и отпишу сюда =)

Stag ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.